1.0.3 Update - Lost whitelist and Voice Column Index

Hello all

I am extremely excited about the new ‘hide rests’ feature, as I’m slowly making my way through some Ligeti piano etudes. The man did not like his rests. Incredible time saver, this feature.

But I did run into two issues with the update:

  1. I’ve lost my whitelist with Pianoteq, which I got working in 1.0.2 after some trial and error. I now cannot get it to work. Has something changed in the process?

  2. Has the ‘voice column index’ property been removed from Write mode? I would lobby to bring it back if that’s the intention. It’s invaluable to any kind of slightly complex piano music, and having to switch to Engrave in order to tweak it (which I do almost every bar) is awkward.

Many of us learned the hard way in the last update that you need to keep a backup of your VST whitelists and install them back in place when Dorico updates. Welcome to the club and sorry for the troubles!

If you have them backed up on Time Machine or a cloud service you can always reinstate the old versions…

Hopefully putting the whitelist back will be as simple as adding:

Pianoteq 5

to the vst2whitelist.txt file, then deleting the VSTAudioEngine folder from ~/Library/Preferences (I suggest you then empty the Trash) so that the engine re-evaluates things next time you start up.

I don’t know whether it would be a useful substitute for not being able to set the voice column index in Write mode, but you can swap the order of two voices with the Edit > Stem > Swap Voice Order command, to which you could potentially assign a keyboard shortcut.

The loss of Voice Column Is is a problem where I want to overlap two voices in a keyboard part: say two quarter notes, one dotted and the other not. That may not be current common practice, but I still want to be able to do it on occasion, and the loss of voice column index prevents that unless Dorico has another way to do it.

There’s an option at the bottom of the Voices page of Notation Options for just that purpose…

Found it. Many thanks.

And the ‘Voice column index’ property has not been removed: it’s still present and correct in Engrave mode.

Thanks Daniel. I haven’t tried trashing the preferences file, and I’ll do so tonight. Hopefully this will work.

As far as Voice Column - I’ve set the Notation Options for the majority of the cases, but still need to override them every so often. As I work mostly in galley view, switching to Engrave mode can be jarring. There are several options in Write that are more Engrave-y (slur direction, for example), and it seems to me Voice Column belongs in that group. I’d be surprised if it really bothered anyone that it was there…

There’s a good technical reason for it having been moved to Engrave mode, I’m afraid, and we won’t be able to move it back, at least not in the short-term.

I’m afraid I cannot get pianoteq back. I have:

  1. Quit Dorico
  2. Added Pianoteq with its 32 zeroes to the whitelist file
  3. Trashed the VSTAudioEngine file from [user name]/library/preferences
  4. Emptied the trash
  5. Restarted Dorico

Pianoteq does not appear in the available plugins in Play mode. Am I missing something? Is there something else to try?

Try this, it’s working for me

Pianoteq 5

Are you on Win or Mac? Sometimes the plug-in names are different on the two platforms.
The name that you have to put in the whitelist needs to be the file name of the plug-in without the ending ‘.vst’

Funnily enough I just added ‘Pianoteq 5’ to my own vst2whitelist.txt yesterday (we are testing the playback of gradual changes for piano pedalling, and Pianoteq is to my knowledge the only virtual piano that supports gradual pedalling at the moment) and it works OK for me. That’s the correct name for the plug-in on Mac.

Try also opening Terminal and pasting in this line:

rm -fr ~/Library/Caches/Dorico

Be careful to paste it exactly, as rm -fr will delete without warning whatever path you enter after that instruction. I think this might give Dorico a nudge towards recreating the VSTAudioEngine folder properly.

There are sample libraries that support it - for example Garritan CFX has an option called “partial pedalling”.

But Pianoteq is probably the gold standard. If you can get legato pedalling working realistically with that, the alternatives should take care of themselves!

The key thing for legato pedalling is to synchronize the pedal release with the next note played, of course - but “synchronize” doesn’t necessarily mean “simultaneous,” depending how legato you want your “legato” to be! And the pedal needs to stay up long enough for the dampers on the bass notes to actually do something, unless you want to use the sustain pedal to imitate the sostenuto pedal.

Alternatively, just provide an option to record MIDI controller data and play the pedalling in live :wink:

The approach we are taking is to provide options for the length of time a retake or a release should take, and we are discretising gradual changes in pedal level using a similar approach to how we handle gradual changes in dynamics. We are trying to handle the sostenuto pedal properly as well, which obviously requires a different approach to both the sustain and una corda pedals.

Ok - I got it! I ended up adding “pianoteq 5 STAGE” (which is the version I’m using) to the whitelist, and it’s working. I’m pretty sure I didn’t do it the last time when I got the plugin to work, but who knows anymore. Thanks all for your input.

Good, that sounds pretty much how I do it with Pianoteq in Finale, using “smart shapes.” (except that having several different smart shapes that all look the same in the notation gets confusing!)

You want the same timing option for an initial “pedal down”, of course - whacking the pedal down exactly “on the beat” doesn’t sound nice, unless you really intend to do it for a special effect.