1.1.50 problems when changing between song parts

I am not sure if this is a bug yet or just a peculiarity of my system but. I have 1.1.50 which seemed to be working very well but I have to day started getting strange behaviour when moving between song parts. It either pauses momentarily as it changes messing up the timing completely or it simply doesn’t swap parts. It isn’t consistent unfortunately but happens about 50% of the time. I am not sure what has changed to day other than the fact that I was messing with the beat module for a while (I have not used it before) . I will report on any further findings but it would be good to know if anyone else has had a similar issue.

The same happens to me.

1 Like

it happened to me too

1 Like

Can somebody give us a recipe how to reproduce it?
Is transport running when you attempt to switch Parts? Then the timeline is not stopped or relocated. Is transport involved at all, or is it all happening in stop mode? What exactly happens? Pls give us more details, thanks!

Ah, now I get it - you use the Play icon on a Part with a trigger time set. Why don’t you say so :slight_smile:
Will check and fix asap, sorry.

The preroll active state has not been taken into account when the Part Play button is used, fixed with the next version. Workaround until then is to set Preroll Bars to “OFF”.

The workaround doesn’t seem to be working for me. I have set pre-roll bars off for all parts but it still pauses when switching between parts as the track plays (transport running). I also still get the issue where it refuses to switch parts. This I managed to reproduce in a small 1 song 2 part project. I set different instruments in the layers for each part so I could show that it genuinely wasn’t switching as (opposed to just not updating the gui.) However when I reset the trigger for the second part it seemed to start working. Either setting the trigger a second time somehow fixed it or it is truly just intermittent. When I get the time I will keep experimenting and give any more info I can gleen.

The preroll enable state is ignored by the Part Play button, that’s the problem. You need to set the preroll time to “OFF” ( to repeat: time, the 2nd item where you set bars).

I have both the pre-roll deactivated and the pre-roll bars set to off.

I must emphasise though that I am not getting consistent behaviour with this. Sometimes it works fine even with pre-roll on and other times it refuse to behave. In addition I am getting two different behaviours when it does misbehave:- 1. refuses to change new part at all, 2 changes to new part but pauses the backing track as it does so. I am trying to create a small project that demonstrates these issues reliably but so far I can get it to do it but then at some point it stops and I can’t figure out why.

It gets stranger.

I just ran this song. The change from the first part to second went fine then it remained on the second part after it should have changed to the 3rd part. It then eventually changed to the 4th skipping the 3rd part altogether. This continued to the end of the song whereby the parts marked “lead” played but the parts marked “accomp” skipped. N.B. The backing track itself played through without gaps it was just the parts that weren’t changing in this case.

part switch issue.zip (1.2 MB)
This is a cut down version of that same project which seems to still exhibit the issue. I note that if you press stop while should be playing one of the skipped parts it seems to jump to correct place in that skipped part (or at least the gui does)
I have upgraded to 1.1.51 by the way but this behaviour was occurring on 1.1.50 originally.

We improved a lot in this area, pls check again with the upcoming version, thanks!