1.1.70 Archived Project Songs Missing Tempo File

Weird. In my previous post I mentioned that:

  1. I had created a test project in 1.1.71, then archived it
  2. Then opened the archive test project on the same device.
  3. It had all the tempo track data is intact.

I closed that test project, but I then reopened that same archived test project, & the tempo track data was not displaying in the tracks.

I repeated the steps above creating a test2 project, archiving, copying the archive files to a new folder, then opening the newly located project, & this time the tempo track data was displaying…random…

Does the local assets folder need to be changed when you open a project that was saved as an archive?

To clarify, in my previous post, the second test that worked was only archiving the project & opening the archive on the same device.

I just repeated my original test using 1.1.71:

  1. Archive a project on device 1
  2. Copy project archive to device 2
  3. Open project on device 2
  4. No tempo track data on device 2 (the tempo tracks are there in the songs but without data in the tracks window)

So the issue is present in 1.1.71 as well.

Works here. You did copy the entire folder to device2, no? There should be a folder “tempo” with it, and in there, the tempo data (ending with “.mprjtempo”). It needs this file, this is why the “Save Archive” function copies it right there, where the .vlprj file expects it, so you need the entire folder.

Thank you for checking @musicullum . Yes, I did copy the entire folder. And to be clear, I created the archive by clicking “File->Save Archive”, then copied the entire Archive folder to another machine, & then in that other machine, used the “Open Other” command in the Hub screen to open the project file of the archived project. Is that the correct way to open the archived project?

Sounds all good to me, but then why does it work in my place?
And once more the question: is there a folder “tempo” and in there, a “xxx.mprjtempo” file?

  • create new project
  • add tempo track
  • add a few tempo events
  • save archive
  • close, copy archive folder elsewhere (or other device)
  • start, open project in archive folder

Does that work for you?

Hi @musicullum . I followed the instructions in your last post, that worked without issue. i.e. tempo tracks created directly in a VST Live project on one device, which can then be archived and opened on another device, and & the tempo tracks are there on that 2nd device. The difference then is that in my project, I created the tempo tracks in a song in Cubase, & then exported the song to VST Live, and then archived the VST Live project.

I can confirm that when I export the song from Cubase, there are mprjtempo files in the tempo folder (though some songs have more than one mprjtempo file for a single song).

I did repeat exporting my main project file to another device & the tempo tracks, while present in the tempo folder, are being brought into my project on the 2nd device, but without any tempo data. So it seems that the issue is more around the fact that the tempo data is not being brought into the project.

Works fine here as well.
There are a lot of possiblilities. Pls let us know all file pathes and settings, here mine:

  • create empty project with one temptrack in Cubase, add some events
  • export from Cubase, setting: Copy Media Files to C:/fromCubase/tempotrack.vlsprj
  • close Cubase, open VST Live, new project
  • Import Media File, setting: new project
  • Save As C:/fromCubase/imported.vlprj
  • save archive to D:/archive/imported, saves D:/archive/imported/imported.vlprj
  • close VST Live
  • open VST Live
  • load D:/archive/imported/imported.vlprj

The D: drive is external (seen from “C:/”). I can also delete the original C:/fromCubase folder to make sure there are no more references. I can also copy the “archive” folder and move it to a different computer and open it there successfully, incl. the tempo track.
So we need to know what is different in your case.

tempo data are always saved to the “tempo” folder and not contained in a vlprj file.

I am following these steps, except I have 2 separate computers.

When I say tempodata is not being brought into the project, I mean that the tempo track is created but it contains no data (or only 1 single position):

At what stage is that? After importing from Cubase (originating where?)? After saving said imported Project (saved where?)? After archiving (where?)? After loading archived project (moved where?)?

Again, it comes down to what was saved and/or moved where. When loading a project, VST Live searches for files whose name is stored in the project. It tries relative to .vlprj with stored filename, then the original, and then local filename.

You may send me the .vlprj file which fails, and I can tell you what it expects to find. At least it would be necessary to know if there is a “tempo” folder with “vlrtempo” file(s) in it.

Let me reiterate that there are several stages where it might go wrong (even though we did everything to cover every possible path), so we really need to know exactly each path (filename) for each step to try to figure out where it might fail. Still don’t have that picture. Finally note we are testing with version 1.1.71.

So, hope this makes it clear:

  1. Create a cubase project on PC1: “c:\cubaseprojects\myproject”
  2. Add a tempo track (with multiple tempo changes - not just a single tempo for the entire track) & audio tracks to “myproject” on PC1
  3. On PC1, export a VST Live project from Cubase (in Cubase, File->VST Live->Export Project), & save as “c:\archivedproject\myproject” on PC1
  4. Copy archivedproject folder to PC2 & store in "c:", so I have “c:\archivedproject\myproject”
  5. Open VST Live, & go to File->Open & select “c:\archivedproject\myproject” & select the myproject.vlprj file
  6. My song tracks are imported into the project on PC2, including the tempo track, but the tempo track has 1 single tempo position & no additional tempo data, so the audio does not change tempo as it did in Cubase, so it plays in an incorrect time.
    Here is the vlprj file for the archived project.
    Beatels.zip (3.0 MB)
    My archived project does have tempo files:

The data is just not there in the track…

And yes 1.1.71

Wait - you are moving the Media Project exported vom Cubase to a different machine?
That’s unexpected.
You are supposed to import this in VST Live, and there apply “Save Archive”. That is an archive function, which is designed for moving projects around. The Cubase VST Live Export Media File function is not an archive function at all (even though it should work, and we will check that).

There is no such thing. The export function creates a media project (vlsprj), not a VST Live project (vlprj) whic is the only option provided with File/Open.

But I even tried and copied the exported folder to a second computer. There imported it with VST Live (File/Import Media Project), and everything is great, even though that is not an archive, as said.
So there must still be something missing from your description, sorry.

No. I am not copying the media project from Cubase to a different machine. I am importing the cubase export into VST Live & then in VSLT Live running Save Archive.

VST Live File-> Open:

Then opening the project vlprj file that was created when saving the archive on the other PC before I copied it to this PC:

It should be pretty straightforward. I create a project on one computer by importing VST Live exports from Cubase. I then Archive that project & copy the archive files to another computer & open the archived project on the second computer. Everything is there in the VST Live project on the second computer except the tempo data in the tempo tracks. The tempo files are in the archived project tempo folder, but the tempo position data is not appearing in the tempo tracks.

That’s different from your previous description.
Thing is, as every possible variant we tried works here, in order to find out what goes wrong at your place, we need to be very picky and specific in describing each step in great detail, otherwise we cannot help.
To recap, there are two distinct file formats, one is vlsprj (with an ‘s’), that is called a media project and is the only format Cubase can export for VST Live. This is read by VST Live via the “Import Media Project” function in the file menu. Assuming we’re clear about that:
After importing this media project, and provided that tempo data are present when archiving, if you now apply “Save Archive” and don’t move, rename or change any files, then copy created folder and move it anywhere, opening the VST Live project (vlprj) file with VST Live always works, regardless of how it was created in the first place (new, or import from Cubase). Even transfering the media project works (you may try that too).
If (or as?) it does not in your place, but we still don’t know what exactly you do, we cannot help.

I suspect that there are side issues that you don’t mention. For instance, maybe the media project that you import has been exported with an older version of VST Live. Or, you are exporting or archiving to folders that already contain data. Or something else gets in the way, you always show larger projects with audio etc; in order to narrow the cause, you need to exclude every possible pitfall and

  • create empty project in Cubase
  • add tempo track and events, nothing else
  • save
  • export via VST Live/Export Media Project into an empty (!) folder
  • close Cubase, open VST Live, new project
  • import media project
  • save Archive.

Whatever I do with saved archive, it will always show tempo track data, on any machine in the world.

Using 1.1.71, I did a test where I created a fresh track with tempo track & exported it from Cubase, imported it into VST Live, archived the project, copied the archive to a new machine & opened the project on the new machine, & the tempo track data was there. I repeated the test using 1 of my existing songs exported from Cubase, & on the new device, the tempo track was there. I then archived my entire existing real project with all of my songs, & when I opened the archive on the new machine, the tempo track data was missing in all of the songs.

I just opened that same archive on the new machine using 1.1.73, & all songs but 1 did have their tempo track data (so only difference was opening the archive with the latest release version).

I installed 1.1.73 on the source machine & recreated the archive using the new version, then copied the archive to the new machine & opened the archive on the new machine. This time, all the songs had tempo data. So it seems that creating a fresh project archive using the latest version (1.1.73) has now resolved the issue, and the tempo track data is displayed in the tempo tracks when the archived project is opened on a different machine to the one that created the archive project. Thank you very much for solving that. I now have the confidence to start programming lights for these songs :grinning:

On a side note, I used VST Live at a show last weekend for the very first time - mostly went well. My USB controller I was using to start & stop tracks did have a hiccup during the show, but I will investigate that further & make any notes in a fresh topic. Despite that, I am very excited to actually start using VST Live in my shows!

Exactly. Thanks for your patience.

Great, let us know how it turned out!