[1.1.84] Monitor-Button in Tracks not working anymore

Before 1.1.84: Pushing the Monitor Button on a track → Playing the direct input instead of the recorded track. In 1.1.84 → Always plays the track.
Have to stick to 1.1.83 for now…

Some more info on this as it’s a quite annoying bug :sweat_smile:

It is not directly related to the version. I think it depends on whether the “save monitor state” function is active or not?!

  • Save monitor state enabled
  • Load project with monitor button active on some tracks
  • Wanted behavior: Track contents do NOT play, but live signal is fed through
  • I switch off the monitor button
  • Wanted behavior: Track plays, live signal is muted
  • I switch on the monitor button
  • Unwanted behavior: both track and live signal are active

Only way to get back to “track does not play when monitor button is active” is to restart VST live.

You don’t mention the type of track, audio, MIDI, …?
In VST Live, audio monitor mode is monitor and play (as with MIDI). If it doesn’t work that way after loading, that’s a bug.
We will add a preference for monitor mode.

Sorry I forgot that info: it’s about Audio tracks.

If the behavior after loading is wrong, then please don’t fix it before adding the option to change the behavior, the monitor mode is currently our only way to send either the live signals OR the recorded tracks to the front :sweat_smile:

(That’s our workaround for not being able to send track outputs to stacks. We need to do a soundcheck without FOH, that’s only feasible when having the same effects applied to the recorded tracks from the soundcheck as in the live situation using monitor mode.)

Got it :slight_smile:

1 Like

Hi, updated to 1.2.1 now!

Could you please explain the three different settings? :sweat_smile:
My guess:

  • Playback: Always plays the track contents
  • No Playback: Don’t Play the track contents
  • Tapestyle: ???

Thanks and best regards,

Playback defines wether or not the track is beeing played back when track Monitor is enabled.
Tapestyle refers to the similar method in Cubase (or other DAWs) which enables Monitor linked to Record, and switches Monitor off as soon as “the tape rolls” (transport is started), and on when record is enabled. This resembles how analog tape machines operate (punch in/out).

Unfortunately, this new function is not quite working yet, should be ok with the next version.

1 Like

What exactly is currently not working? I updated to 1.2.1 and the next Gig is in a week, should I downgrade again to be on the safe side?

Everything is working as before - which means that the new options don’t work, so no need to worry at all.

1 Like

You should now find a preference Audio/Track Monitor which you can set to playback or no playback. Hope it works for you.

Testing it out tomorrow evening, thank you!