[1.1.87] Track Problem using an Archive

We noticed yesterday that an archive created with version 1.1.87 does not load completely. We have 30 songs in the setlist. For each song there are three audio tracks in the tracks where we use Mp3 files. In the current version, however, only the audio files for the first song in the set list are loaded; for the other songs, the tracks show that an audio file actually belongs there, but it is not loaded and only displayed empty. Unfortunately I don’t have a screenshot, but I’ll test it again. I was able to manually insert the audio files belonging to the archive into the songs in order to be able to work with the archive, but the settings on the tracks (tracks) were all fully included.

Just tried it with the most complex project available - no such problems.

When you import an mp3 file into VST Live it gets converted to .wav. When saving an archive, those wav files are copied to the destination folder. Are those files present in the folder you load the archive from?

Does it print “Media Offline” in those audio events? If so, we need to find out where those files are. You could send us the .vlprj file, and we can tell you where it expects the files to be found.

Hi Musicullum,

When I reopen the Archiv on the Computer I created it on, everything is fine, no problems but I copied the Files via an USB Stick on our Rehearsal Computer and then happend the Problem I described.

All the .wav files where created and also copied to our rehearsal computer but only the three files used in the first song of the setlist where loaded. I manualy droped the .wav files then in the tracks to make the setlist work again but that was a lot of work.

No. There was no “Media Offline” print. I first didnt recognise the problem until we reach song two on the setlist where nothing was playing! I add the .vlprj file from the Archiv here in a ZIP-file
Setliste.zip (2.8 MB)
.

That is very strange. From your file, I would assume it finds everything but the first Song which lacks a relative file name (it should work nevertheless).
All original files are in D:/Onedrive/Dokumente/VSTLive/projects/audio/Gig. Does this folder (also?) exist on the Rehearsal Computer?
And: not knowing the path where you created the archive, there should be files in the archive next to the .vlprj file such as “pathToProject/audio/Gig/The_Weeknd_Save_Your_Tears(Backing).wav”. Does that file exist in the archive folder that you transfered? If so, there is no reason why it should not find it. Once we know that, we can further investigate.
btw personally, I avoid OneDrive, it can lead to quite some confusion, but that most probably has nothing to do with your problem.

As I wrote, the first Song (welcome to the DCC) worked all other not.
The path is correct and the file you named also exist. Thats what confuses me. Everything is in place and on my main computer where I created the project file everything works also wit the archive but not after copying everything to the rehearsal computer?!
I did not have any problems using onedrive in all this years with cubase and all other Steinberg Software. If there is a path problem, it should lack with all songs in the Setlist.

As said, I don’t think it has to do with OneDrive either.
Will continue to analyse this, very weird.

Took a look at the project file you sent to me again.
What concerns me is that you claim the first Song plays, but the others don’t.
From the project file, it should be the other way round if any. As the first Song plays, there should be a file “D:/Onedrive/Dokumente/VSTLive/projects/audio/Gig/Nothing_But_Thieves_Welcome_to_the_DCC - Vollständig.wav” on the target computer, correct? Could you please let us know the full folder path to where you copied the archive? Is it “D:/Onedrive/Dokumente/VSTLive/projects/???”?
Thanks!

Created arbitrary audio files where they should be named like yours, and applied another check to find files, I can resolve one missing file. So pls try again with the next update.

Yes the file “Nothing_But_Thieves_Welcome_to_the_DCC - Vollständig.wav” is available.
I saved the Archive directly to an USB-Stick “I:” and from my point all necessary files where created/copied but the only the first song worked like expected.

I am currently on version 1.1.87.738 and I will use this version to save an archive to:
D:\Onedrive\Homerecording - Detlef\Band - Tyres on Fire\VSTLive-Setlisten\20230624_Tyres on Fire - Setliste
I will copy this folder to an usb stick to transfer the data to the rehearsal-room computer.
If there is a new version on Friday, I will do a new Check with the latest version.

I think with the fix any of the archived project should open fine. If not feel free to complain again!

1 Like

I did the next test with 1.1.87.738 yesterday and nothing worked as it should!
I saved a new Archive to: D:\Onedrive\Dokumente\VSTLive\Tyres on Fire - Setlist-Archives
VL created a folder and saved the .vlprj (see attachment) and also a folder “audio” and a folder “marker”. Inside “audio” are all needed audio files for the project. I checked a lot of them and they work as they should.
However - After loading the project file in VL the file did pretty nothing. This time NO song in the setlist worked. All external media was shown as “Media offline”.

Projectfile:
20230624_Tyres on Fire - Setliste.zip (2.8 MB)

So we are now back to the manual MP3 Playback for our Backings because I do not have the time to drop all audio filed manualy “again” into the VL-Project file to make this work again as it did on my main computer.

The fix is not in this version yet, coming very soon. But just in case: audio files in the archived folder are present in audio/Gig, correct?

1.2 is out now, give it a try?

No. There is a folder “audio” inside this folder are all the external Soundfiles - there is no folder “Gig”.
Sould there be an “gig” folder inside of “audio”?
I will test 1.2 now (lokal here on my main computer) and will show you what is inside the archive.
Thanks for your help!

No. Some older Cubase exports had this in their name.
It should find projectFolder/audio/filename.wav if that file exists in that path next to the .vlprj file (projectFolder/myProject.vlprj).
If 1.2 still doesn’t work just let us know.

Unfortunately there was no improvement with version 1.2.0, as the screenshot shows, all external media were displayed as “offline” and they didn’t work either.

Screenshot Version 1.2.0

With version 1.2.1 there was now an significant improvement, the files were no longer displayed as “offline” after loading the project file, but in each song in the setlist a external file was shown correctly but only displayed in the top track, so that you can see the typical “WAV” waveform here in the topmost track.

Screenshot 1.2.1 - No “Media Offline” Message


I then clicked the remaining “empty” tracks once and after clicking they also show the “WAV” waveform, but only the track that was just clicked and the top track also (example 1 and 2) if you then click on track 3, the waves are in 1 and 3 displayed.

Screenshot 1.2.1 - Clicking the Tracks

But the good thing is that even if the external files are not visually displayed correctly, all files work. So you can work with this version again. Maybe you can still find out what this display problem is?!

Question: Are we the only ones noticing this problem?

Very good to know, thanks.

Yes, stumbled across that obne myself, we will check. Thanks so much for your continued support!

1 Like

I am still using 1.2.1 and preparing our rehearsal tonight and I want to let you know that during the “Save Archive” process some “export Windows” appear (empty) but show a red mark on the right side of the window. These Windows are empty so that I can not see if there is a problem or not but a red mark doesnt feel good.

Here is a shor screenrecording
VST Live Selector-Drag

I don’t think there’s a problem, it’s just the progress bar going too fast. Will check to omit it when short files are to be copied.

1 Like

I could testrun VSTLive 1.2.2 yesterday evening at the rehearsal but there was noch “visual” improvement to 1.2.1. Only the topmost Soundfile in a track is shown correctly - all Tracks that follow are shown empty - but if you klick on them, they are shown up (one at a time) so you have to choose wich one you like to see.

1.2.2
Old Screenshot of an existing Problem