1.1 Playback problem.

When I press playback the green bar disappears? Or stays static (it varies).
The playback is also slightly erratic. But the main problems is the disappearance of the green bar on playback.

Are you on Mac or Win? What audio device are you using and what are the settings, especially audio buffer size?

Hi, I’m on a Mac, I also tried it with just one instrument and even without an instrument loaded and it’s the same.

Could you please zip up the folder /Users//Library/Preferences/VSTAudioEngine and post here. The log files will help us identifying the problem.

Im sorry, but I dont have this?
If I go to my HD root and dbl click my options are Users, when I dbl click on that and then my user name - I do not have a file called Library?

If I go from the HD root I have a folder called Library - then Prefrences but nothing called VSTAudioEngine?

Actually, it is a hidden folder which Finder doesn’t show you directly. You could either open a console and type in the path, or there is somewhere in the Finder menu an item called “Go to Folder” or so. At home here I’m on Win and have a Mac only at work. Tomorrow I can give more precise info.

The easier way is to do Help -> Create Diagnostic Report, which will leave a file on the desktop called Dorico Diagnostics.zip which you can attach here, or send us a direct message if you prefer.

I’m having a similar issue.

The audio seems to play back fine, but frequently the green playback wiper, the time display, and the play button freeze. When I press the rewind key command (the period on the num pad), the music will play from the start as expected (always, or almost always), but the wiper and time display remain frozen.

Sometimes the issue goes away if I toggle the display of MIDI data in a lane (i.e., change it from hidden to displayed or vice versa), but it returns soon after.

This happened with the same file on both on a 2009 Mac Pro with audio playing through a Metric Halo ULN-8 and on a 2012 MacBook Pro played through internal speakers.

Bob

Mac Pro (Early 2009)
2 x 2.26 GHz Quad-Core Intel Xeon
40 GB RAM
Mac OS X El Capitan 10.11.6

MacBook Pro (15-inch, Mid 2012)
2.6 GHz Intel Core i7
16 GB RAM
Mac OS Sierra 10.12.5

Dorico 1.1

This is a known issue. We can reproduce it here, but we still haven’t managed to get to the bottom of why it’s happening. It only happens on mac.

We are further interested in: You say that playback is slightly erratic. What does that mean? Are notes missing, in the wrong order, wrong length, wrong…?
What if you do an audio export of the piece, is that fine or also erratic?

No sorry, I worded that wrong, the green bar is erratic, the playback is ok but the green bar does not follow… Sometimes it stays were it is, sometimes it starts to move and then disappears… Other times it disappears when I press play.

You may find that wiggling the mouse pointer around the screen “unsticks” the playback line, and you may also find that switching modes, e.g. to Engrave mode and back again, either by clicking on the buttons in the toolbar or using the shortcuts Command-3 and Command-2, get things moving again.

I’m sure we will eventually manage to get to the bottom of this, but so far we have been unable to. The problem is difficult to reproduce on demand and is therefore difficult to debug.

Hi There!

Just wanted to chime in that I just witnessed this problem. I’ve occasionally seen the playhead indicator get ‘stuck’ while playing, but this was a bit more severe.

Notes:

  • First time running Dorico after upgrading from 1.0.3 to 1.1
  • 2016 MBP 15-inch, macOS 10.12.5
  • Window was originally full screened (it’s own ‘space’ in Mission Control), but its behaviour was consistent when I reverted to windowed mode.

Issue:

  • No changes in the content window during ‘Write’ mode- Any note entered, changed, highlighted, etc. using the keyboard commands would not show in the main content pane until I scrolled any distance.

The application knows I changed the notation- It would play the right notes as I modified the notation, but it would not visually present the update. I feel as if it’s tied to window redraw not being triggered, and the only thing I could do to cause a redraw was modifying the physical scroll position or pressing play, but it would only update for one frame at a time.

Restarting Dorico, this behaviour ceased. Additionally, later opening the application, selecting it to open in low resolution did not affect anything visually, aside from resolution.

PS. It’s worth also noting, that when the application is functioning normally (for me), the playhead seems to move ‘choppily’. Similarly to above, if I’m constantly scrolling while in playback, I can see that the playhead is moving perfectly smooth.

PPS. Log from major affected session attached.
VSTAudioEngine.log.zip (4.92 KB)

Edit to my previous post: I’ve been able to re-trigger this issue by bringing up the mixer, which thinking back, was before I noticed the issue in the previous session, as well. Changing in-and-out of “Write” mode fixed the issue.

I have similar problem and I’m on Win 10. Sometimes the green bar gets stuck although it still plays. It only has this problem on the playback page, not on the write page and its intermittent.

Are you serious, really on Windows? Because so far we have only ever seen this on Mac. If it also happens on Win, well, that opens a whole new dimension…

No, I’m not joking. It gets stuck sometimes. If I quit the program and restart it clears it up, or sometimes flipping pages works but not always.

I don’t think its related but I also get intermittent glitches in the playback, although that may related to using East West Play VST3. I’ve tried different ASIO drivers and settings that’s made no difference. I haven’t heard the effect with Halion yet but I’ve also not used it much.

Would you mind telling us your system’s spec?

Desktop, I7-6850K, 128 GB RAM, Gigabyte X99 based Motherboard, Gibabyte GTX NVidia 1060 graphics card. Anything else you need?

Thanks, that’s enough. You have a decently equipped machine, so horse power can not be an issue. On my rather old and slow MacMini I frequently see that problem with the green line not moving. But as already mentioned, it is very difficult to reliably evoke and also debug.