1.2 - Note duration key command bug?

Great release! :slight_smile:

After updating to 1.2 the Alt+Shift+Right/Left now doubles/halves the note duration, instead of increasing/decreasing by grid value.
Doesn’t matter if I try to reassign the key commands - even after assigning “Lengthen Duration by Grid Value” to Alt+Shift+Right, it still doubles the duration…

Anyone experiencing the same behaviour?


Unfortunately this can happen. We’ve tried to make it such that your existing key commands are brought forwards into Dorico 1.2 while automatically adding any new default ones, but the rework we’ve done to the duration editing commands is incompatible with existing key commands in some cases. You should be able to find ‘Double Note Duration’ and ‘Halve Note Duration’ and delete the key commands assigned to them, then go and reassign ‘Lengthen Duration by Grid Value’ and ‘Shorten Duration by Grid Value’.

If that doesn’t work, you have two options: one, click ‘Reset Key Commands’ and then set your custom key commands up again (which would be annoying, since we tried quite hard to prevent that from being necessary in this update); or two, gird your loins and open the keyCommands_LANG.json file from your user data folder in a text editor, and remove the troublesome lines by hand. If you’re not sure how to do that, send me your JSON file and I’ll do it for you, and post the steps here for others to follow.