1.3.21 - Setlist editor issues :'(

Hi! It was working correctly in the last recent times. With 1.3.21 I’m struggling to edit existing setlist:

(P.S.: I will do now a comlete reinstall to exclude recent issues are coming from a solvable issue)

Uninstalled / restart / reinstall / restart. Same, nothing has changed.

Trying to trick out setlist editor, back to song list, there is also something (sometimes working, sometimes not):

Hi @musicullum !
Unfortunately experiencing Setlist-Editor-Issue booth on MacOS ( VSTL 1.4.12) and Windows (VSTL 1.4.7) at song deletion.
It might not occur at first deletion sometimes, but after changing-setlist, cleaning, changing… it happens then. It’s deleting “the neighbour of selected” instead of selected one:

Hi @fkalmus,

I cannot reproduce it. Maybe it’s related to your project? Do you think it is possible to share us the project file (*.vlprj")? We only need this - no media file… Or, PM me.

See you,
Michael.

1 Like

hi! just letting you know, quickly tested with recent 1.4.51 and issue persists with (so we can exclude “re-installation problem” then).

Still on our list, sorry for delay.

1 Like

Hi @musicullum , Thank you for your reply. And no worries:)

I tried very hard to reproduce it, but to no avail.
I can see in your video how it goes wrong, but how on earth do you get there?

Anytime, anyhow, but really. I can’t wipe out old songs until deleting from all playlist but for months, I haven’t been able to get there to delete them, because quickly closing the project unsaved at first miss-deletion.

trying on Mac, same result with quickly running through the first 3 setlists (same proj that I sent) and clicking to delete songs within playlist.

Sorry, there are a lot…what project?

The same with (or an previous copy) that I PM-ed to @Spork about 10 days ago after his request for vlprj file.

Would it help to send a copy of my *.vlprj to you as well?

Thanks, I’ll get it from Micha.

1 Like

I tried for half an hour but to no avail.

Could you try to narrow it? When the bug appears, are there any special conditions?
From your video I see that you select a setlist, but not activate it, correct?
Also Sync is not active, is that also true? Maybe it has to do with the Song names, like starting with “—” or whatever…

If you could provide a step by step with the project you sent, that would be very helpful. To me it looks like it depends on what you do beforehand, like adding Songs, selecting different playlist, activate or not activate, sync, delete here, select another setlist then delete there…tried all of that and more.

Dear @musicullum , that soundz totally craisy, I need 10secs anytime. I just open my project.

  • Opening VSTL with my “live” setlist (Musor2023 or Xmas2023).
  • Clicking to open SETLIST EDITOR
  • Clicking to e.g. my 1st SETLIST (Petőfi est)
  • Selecting 18th song “–Sleeping Beauty” for deletion
  • Clicking “-” above Song list (3rd column)
  • bang, miss-deletion. Thats all what I have to do.
1 Like

Got it. weird that I couldn’t force it…will check and get back.

At position 19 in your first setlist, shown as “–Sleep…” something, there is a Song that does not exist (and thus, is not shown). But internally, it’s still there…This project has probably initially been created with an old version of VST Live (1.1, probably) which had a bug causing this.

Anyway, we could fix it, and the fix will come with the next version.
Loading your project with the next version and saving it again it should also clean it up.

Thanks for your patience!

2 Likes

seems to be working perfectly with 1.4.52 :slight_smile: