1.4.61 Always Preload Parts Doesn’t Work

Checked against 1.4.60 which is fine.

The preload parts works. What not works is the “always preload” checkbox. You have to start the preload parts manually at the moment.

1 Like

That’s what I meant - always preload parts is checked but it doesn’t preload parts… :grinning:. Have corrected the topic title

Cannot reproduce that. Do you have a step-by-step procedure?
When “Always preload” is ticked, it will do so whenever you load a project, no?

Correct. Normally I would see VL step through the songs after the project has loaded and it is not now doing it.

This is on Sonoma btw

I have the same behaviour. Preload parts dont start automatically. I can check and uncheck the box, restart VSTL, but nothing changes. Preload dont starts automatically.

1 Like

Still cannot see how that is even possible.
Is this with both “Preload” and “Preload Parts”?

Yes both are checked. Would you like the project file?

I‘m running VSTL on win10.
Both are checked

Yes please.
But my question was if ignoring the auto check happens whether you run “Preload”, or “Preload Parts”. Also, when no preload happens and you open the preload dialog, is the box ticked? Thanks.

Ah…. - Sorry I should have seen this earlier, there’s a mix up in the Preload and Preload Parts flags.

Steps to reproduce:-

  1. Turn off Preload and Preload Parts.
  2. Turn on Preload Parts.
  3. If you now look at Preload - it is checked when it should be unchecked.

Or

  1. Turn on Preload and Preload Parts.
  2. Turn off Preload
  3. Look at Preload Parts - it is now unchecked when it should be checked.

But what you mean “turn off”?
You can activate either Preload or Preload Parts via the File menu. Ok.
In the dialog, you can tick or not “Always Preload”.
If that is ticked, it should apply the last preload action - either “Preload”, or “Preload Parts”, whichever was selected last - whenever you load a project.
Confused…

Turn off = uncheck “always”, sorry always referring to “always” - bad shorthand at my end

That contradicts itself.

If you “turn it on”, it is checked, and it should, why would you expect different?

There may be confusion about “Always Prelod”. This applies to the last action, not seperate for each of the 2 types. You can either Preload, or Preload Parts, not both.

… but changing “always Preload Song” is affecting “always Preload Parts” and vice versa.

cross-reply :slight_smile:
It is affecting whatever you chose the last time, these are mutual exclusive.

I know they are supposed to be mutually exclusive but that’s not what’s happening

I’m open to a Zoom meeting if that would help

My bad - I’m sure they were both checked before.