1 Beat loop bug (broken audio)

I run into this looping bug on a 1 beat loop all the time (video attached below)

It’s very bad when using elements that have been processed with spectralayers, even after you have exported from spectralayers and removed all instances of spectralayers from the project.

I also have these kinda bugs whenever there is a musical mode enabled on a sample anywhere in the project, even if its not the samples that are currently being triggered, just having it enabled somewhere in the project will cause it.

This has been around for years now, when can we get a fix to this unbearable bug .

I tried quickly to reproduce the problem when musical mode is activated for any event in the project. My playback was still normal, though.
PC, Cubase 12.0.60

The above video was a demo of the issue with spectralayers not the musical mode bug.

The musical mode bug is a little more unpredictable as it sometimes behaves and other times doesn’t.
4 other producers i know have the same issues so i know its not something on my end.