10.0.40 - Disable/Enable Track do not restore Track Quick Controls settings

Steps to reproduce:

  1. Create new empty project
  2. Add one instrument track, for example HALion Sonic SE
  3. Open MixConsole and click “Racks” button, then click on “Track Quick Controls” - so it is checked. Now you see QUICK rack bellow all other racks. Edit Track Quick controls as you wish. (example : S1 Mute, S1 Solo, S1 Volume) Check if it works.
  4. In project window click right-mouse button on newly added track of HSSE and select Disable Track.
  5. Re-enable the track. Although the Track Quick controls say S1 Mute, S1 Solo, S1 Volume as previously assigned, they now control default controls read from the plugin (S1 QC1, S1 QC2, S1 QC3)

NOTE: Even when you save the instrument track with assigned QC controls as Track preset, the situation is the same : The names get loaded, but they still control the default controls, not what you assigned.


Can you confirm please this is new since Cubase 10.0.30 or was it the same in the older versions already?

this is not working at least as far as Cubase 9…

Huge +1 to this nasty bug, please get this fixed ASAP.

Cant beleive there are still issues with track disable/enable after this time

Note: for the repro to work you must set Quick Control destination parameter to something other than the default

E.g sampler track QC1 set to filter type, ends up controlling Cutoff after re-enabling…extremely annoying and time wasting.


Confirmed…does it in 10.0.30. Honestly not sure if it ever worked correctly.

This bug goes back quite sometime and honestly I thought they were supposed to be getting better at this bug squashing thing.

This is still not fixed in 10.0.40. Looks like it can be fixed easily as saving QC preset and re-loading it after the disable/enable cycle loads proper values. Pretty please Steinberg!

Still not fixed in Cubase 10.5…
Please Steinberg, this is getting ridiculous. This bug has been there since years and makes Quick Controls completely unusuable in deactivated templates. :frowning:

Still not fixed in Cubase 10.5.20

Video here : https://youtu.be/hTAZfzvJ7ew



Cubase 10.5.20 is the latest update so far.

Yes, but it’s stated and illustrated above that this bug still remains in 10.5.20.

Seems like this is fixed in C11! Please test people!


I can confirm the fix.