10.0.40 Update

after reinstalling Cubase from a freshly downloaded file, still no result. Windows settings were all good. Then I started looking at the files I used. I used mostly Symphonic Orchestra and I could not play any of the samples.
Turns out that the update destroyed the file with the locations settings for Symphonic Orchestra. After relocating them and a restart of Cubase everything works again.
Very sloppy update. Not amused.

Well that’s a shame. :frowning:


With regard to the wrong elicenser version, I did this (you need winrar installed on your system):

  • right click on “Cubase_10.0.40_Update_win.exe”
  • select ‘Open with winrar’
  • Navigate to ‘Cubase 10 Update\Additional Content\Copy Protection Driver’ folder
  • replace ‘eLicenserControlSetup.exe’ with latest version (6.11.8.9256)
  • Close winrar and update Cubase without elicenser problem

As I reported in a different topic…
I also updated to the latest eLCC software (v6.11.8.9256) prior to updating to 10.0.40. The CB update did not change the eLCC to a previous version. Weird.

Regards. :sunglasses:

Yeah it’s a bigger shame as it came so late in the C10 life cycle too (Presuming C10.5 hits when we expect)… And was a big part of many users upgrading.

I’d like to think that maybe if enough people made a stink they would offer good pricing on the upgrade to C10.5… Me personally, i can’t see myself jumping on C10.5 straight away based on the long dev time for C10… But we’ll see what it offers before jumping too many conclusions… But yeah, they need to think about the effect this has on people’s mindsets of upgrading on day one or not.

Yeah that really is strange, did you not get any kind of install notification for eLCC when upgrading to 10.0.40? I updated within an hour or two of the update going up, so perhaps it’s something they’ve since fixed?


I did not notice any kind of eLCC installation notification during this update. I estimate that I downloaded/installed the CB update maybe 6 hours or so after the release.

I have complained numerous times to Steinberg about the eLCC getting “downgraded” to an older version during CB updates. I was told that the CB installer checks for a newer version of the eLCC and it will install it. For me, that was not the case until about a year ago when my eLCC version stopped being downgraded. Who knows… Steinberg should review for sure.

Regards. :sunglasses:


About the eLicenser issue: I saw during the installation of the update installer on my 10.0.30 system / Windows 10 Pro / 1903 (without the latest feature KB) that eLicenser software was installed/updated, which surprised me. As usually, I started the eLicencer control center after the update and it threw a couple of errors about too old / outdated files and components. Then I downloaded the latest eLicenser installer from Steinberg and installed it and after that the control center opened with no errors. Also CB 10.0.40 opened without any problems.

Anyways, not very professional and a bit concerning. Should not happen…

Regarding the elicenser rollback which also happened to me with this update. If Steinberg has a logical reason for doing this I suppose we would appreciate an explanation otherwise it is simply an error on their part and could have been avoided with due care and attention on their part.

My experience of this update was identical to etchell’s, above. IMHO the elicenser debacle is unfortunate, but not a big deal, since it was so easy to fix.

/Magnus

10.0.40 has arrived.

2 days ago! :wink:

Why was this update not officially announced as others have been in the past?

+1

Regards. :sunglasses:

I agree, it would be extremely bad practice and false advertising. The ARA2 implementation in Cubase 10 is a disgrace and it’s so flaky, undocumented and missing parts, it’s an utter embarrassment. For the first time in about 30 years I’m considering moving on from Cubase to Studio One, which I’m demoing now. That’s a really big deal for me, I’ve stuck with Steinberg through thick and thin and it’s only been in recent years I’ve actually had to join this forum. I’ve no idea why Steinberg feel they’ve got to cram in so much half working, useless garbage, but I suspect it’s so the marketing department can tick box’s, whilst ignoring that the stuff just don’t work like it should. I’m just so disappointed with Cubase 10.

Probably as it’s not carrying anything major? I.e. ARA support was quite substantial.
But yeah, it is odd, if it weren’t for the forums I probably wouldn’t have been aware.

I did the transition to Studio One 4.5 after de 1st failure about ARA and some annoying bugs…