10.0.50 is ignoring & over riding set 96K to 48K

10.13.6 all updates, MP 3.46ghz 64G nV TitanX MIDI express XT, tascam 20X20
projects are all 96K
audio hardware - Tascam 20X20’s is externally word clock locked @ 96K
audio midi setup is set to 96K
with 10.0.40 this worked all fine.
with 10.0.50 it seems to be under the hood locked to 48K no matter what. if I change project setting to 48K and set interface(s) to 48K and let CB set the audio midi rate to 48K ( or I manually set it ) then I get sound out as expected.
otherwise, if I have the 20X20 set to external clock = 96K, audio midi set to 96K, CU project prefs set to 96K and studio settings->20X20 set to external clock… then no sound. this had of course been perfectly reliable and fine in 10.0.40. I guess I may take a retreat to 10.0.40 to get this sorted out as I have actual work to get done that can’t take hours of messing around. none of the usual flip this back and forth of settings works. 10.0.50 is locked on using 48K. in fact in project settings when everything externally is set to 96K and project set to 96K, I get an unsupported sample rate error in the dialog box. scream, groan, I"ll mess with this for a few more minutes before uninstalling and going back to 10.0.40.

UPDATE : I found the problem. Its the Pure Evil™ apple QT player X in the background being open. This app has the worst written code ever. Every time I set the rate to 96K, QT player X reset it to 48K. Quit QT player, everything back to normal.