10.3 significant CPU increase & delay when selecting different midi track

Anybody else seeing this? I have 3 midi channels triggering VEP on slave pc & each time I select a different channel Nuendo chokes for about a second, real-time peak spikes then playback continues from where it should. Same scenario & same project in 10.2.20 is fine. Suspend VST3 plugin process when no audio is received on or off makes no difference.

This sounds like you have the Asio Guard enabled which does not do well with VE PRO. Make sure that is disabled.

Thanks composingkeys - that seems to have resolved the lag but the pops and clicks make 10.3 unusable. Asio Guard is on and has been on in 10.2 with no issues running VE Pro.
10.3 asio guard off.png
10.3 asio guard on.png
10.2 asio guard on but no delay and no pops and clicks.png

If you have to use Asio Guard, try setting the level to low as I’ve found that if you have a lower buffer like 128 or 256, it usually can get away with not causing the lag. That may improve performance.

Is Activate Steinberg Audio Power Scheme enabled? Is Activate Mutli Processing enabled?

Thanks again composingkeys- setting asio guard to low in 10.3 seems to have resolved the trk select = choke. The attached pics are the same project though…it’s literally 4 midi channels: Retrologue & Battery local, Kontakt Drumkit & FM8 from VEPro slave pc & practically no effects. Something has definitely changed w/ 10.3
Activate Multi Processing was enabled- I assume by default - I never needed to tweak these settings in 10.2 & I’m on a mac so not sure if the Audio Power Scheme is applicable. thanks steinberg for making the 10.3 a side x side installation.


That’s too bad it didn’t help! I thought perhaps 10.3 changed some of the settings since it is not an update but a new install from Nuendo 10.2 from what I understand. If all the settings are exactly the same, then it does look like there is a CPU difference. Hopefully Steinberg can take a look at that.

https://www.steinberg.net/forums/viewtopic.php?f=291&t=191448

This was acknowledged in my initial post. Issue with high load in 10.3 vs 10.2 persists.

I don’t believe this is native to 10.3 only, unless you mean you load the same project
back and forth between N10.2.20 and N10.3.

It almost always happens here if the buffer size is set very low, like 64 or 32 samples to record MIDI,
and just enabling record on a MIDI track will get the CPU peaks and jumps.
It may vary on other systems though.

Believe it. Pardon me if I didn’t make this clear but yes, it is the same project, same computer, same drive, same everything. I’m going back and forth between 10.2.20 & 10.3. The variable is the version of Nuendo.

LOL!
I take it you are not a native English speaker.
The expression “I don’t believe it is native to 10.3”, in this context
means " I don’t think it is native to 10.3", and it doesn’t mean " I do not believe you"

I do believe you.

‘Believe it’ in this context means “I assure you, it is only happening for me in 10.3.” And again, pardon me for not making that clear in my previous posts. I’d be delighted to get back on topic if anyone else can help.

wait to see when you go to Cubase 10.5… You’ll gonna miss 10.3…

I left cubase 10.5 for Nuendo 10. So far I would prefer to have my money back.