10.5.10 update -> privileged helper has wrong version!

I’m stuck in the middle of a cubase update from 10.5 to 10.5.10 with this window (below).
The sofware seems to be updated but sound libraries don’t.
Please help needed.

https://www.steinberg.net/forums/viewtopic.php?f=283&t=179800

That thread only points out that you are not alone. There’s this one too.

https://www.steinberg.net/forums/viewtopic.php?f=283&t=179800

Steinberg’s response doesn’t fix the problem and they have not responded any further to those who have tried it with no success. It seems that they need to fix the library manager. One can only guess if they are working on it.