10.5.10 - VST3 abnormal CPU consumption fixed?

According to the issues it should be fixed in the update, but the release notes say nothing.
My question: is the problem with VST3 and the abnormal CPU consumption been fixed in this maintenance update?

In my opinion. It seems worse (Windows 10 Pro), the track I just about managed to mix at the weekend on 10.5.0, no longer plays on 10.5.10. I’m going back to 9.5 in the meantime. (since 10.0.50 is broken too and I don’t want to roll back ro 10.0.40 at this point and 9.5 is solid)

on windows? windows 10?

EDIT: you changed the text, after i quoted you. on windows 10 pro. alright. i am also on windows 10 pro (1909, all updates).

it says nothing in the release notes about the vst3 problems. which i assume a suspend state issues.
i didn’t experience spikes. only the odd thing, that some vst3 plugins on send effects set the average load to 90%, and when played it goes down.
that now is gone, it seems. and i experienced with one project mixdown problems, but that works now. if work with that project, i hope, the mixdown problems stay away. it brakes my workflow (i want to listen in between on other system).

it is a strange update, with strange release notes.

I’ve updated my original comment …

i saw it. strange. the behavior is different. no abnormal cpu use, the average load meter isn’t representing the cpu of course, and for what i use, it is correct. low cpu use in fact, but we all know, how many factors are involved. i think it could be better, or the use of sidechains, send effects, and plugins with abnormal large latency (for sound design, not mastering stuff), and the soft synths i use, are known to blow the load. so me thinks i am lucky, it is within normal parameters…

EDIT: cubase 10.0.5 pro was very stable. more reliable than 10.5.10, or it just a feeling. not about 10.0.5 which was, i repeat, very good, worked very well, on 2 systems, both windows 10, other specs, intel proc’s.

Also Windows 10 user here.
Some projects seem to work fine on 10.5.x but with some I get the Performance meter (CPU) randomly peaking with audio drop out as a result, sometimes it seems to get stuck on peaking for 10-15 seconds and the sound wont even return until I stop/start the song again.
I wasn’t really using any version 10.0.x and I never had these problems in 9.5.x.
I see no behavioral difference between 10.5.0 and 10.5.10.

I would instinctively say that the difference between the working and non-working projects is what vst instruments are in use.
My system has more than enough resources for this not to be related to the system itself and I have gone through and updated all software, drivers and firmware related to audio processing.

I’m on a: i7-7700K // 32GB memory // Nvidia 1070 // Lots of monitors // Nektar P4 // Focusrite Scarlett 18i20


would you be able to identify some plugins that do this?
If you can also provide how-to reproduce, please do, even better if possible in a stripped down project (audio track -> direct send).

Thank you!

i can only provide this information: the ACME Audio Opticom XLA-3, when it was loaded directly to an FX channel. but this was on 10.5, not 10.5.10 anymore. i didn’t mentioned that properly i see now. but i installed it yesteday, when i come across the same thing. i will try for instance the soft modular FX, that couldn’t work on an FX channel, load to high, but as insert no problems. but again that was 10.5 (on windows 10, 1903/1909).

there is nothing about the vst3 suspend state bug (i call it that way, because it looks like when in suspend some code is going recursive… or something else…) in the release notes, for 10.5.10. for windows (and mac). but not all things changed are stated in the release notes. the new vst2 plugin scanning for example.

EDIT: i wrote it past tense, so i assumed it was clear. i was talking about the strange behavior on 10.5.

Oh, I see now, thanks for clearing that up!
That should be fully fixed, so reading that scared me a bit.

Oh, and to reply to the OP: yes, it is part of the update.

ok, thanks for the confirmation. and indeed, i can put softube modular FX on a FX channel, as a send, on an already “hot” project (i mean averege load meter, which is of course only indication of the load, at a load at 60%, you can still add stuff, and it doesn’t get higher. untill…), it introduced a very minimal, or even not noticable average load meter load… so that is also fixed… (i tried a heavy FX, 3 x tsar-1 reverb within softube modular, with 4 delays, a preset of softube. i make my own presets… but strangely this test has gotten me a new vibe for one sound… that is besides the point).

the same project, 1 x LION, 1 x pigments 2, padshop 2.1, 3 DS audio thorn, MSoundfactory, with meldaproduction effects, and some other effects, i had to kill the “export audio mix down” process several times, before it could work, in 10.5, now in 10.5.10 it works right away.
but cancel the “export audio mix down” does not work yet… i must kill the process… and afterwards it is “broken”… cancel is quite handy if you notice, that you muted a channel…

there is no mention of the export audio mix down problems, but perhaps they were related to the vst3 suspend bug?

i will work in my studio this day, tomorrow, and perhaps all week. i didn’t had a good feeling with 10.5, with 10.5.10 i have a better feeling.

thank you for your reply. and sorry for my confusion.

a lot of people seem to be confused, i got a private message, from someone, who asked is 10.5.10 also for windows?

i know you respond on this forum, and do a great job.
communication with users is very important (see native instruments forum, lately even developers show sometimes up, to say a word, or even reply extensivily, although in general terms, about the development, but a lot anger was on that forum. it is now almost gone. it slightly back again, because of a bug, that renders maschine useless for me now.)

i hope that you do not get me wrong, i take this opportunity, to tell, in reasonable way, in a forum i always stay reasonable. even with support tickets, that are a half year old (other company…) and no response…
i repeat, i am glad you responded, and i can read out of your response that vst3 problems must be fixed. many users wonder if it is. do not dare to update, or…

and i hope i don not step over a line. even a small user as me, who loves cubase by the way, and yes experienced a few bugs, but all were eventually resolved. i know my stuff. but a lot of people, have questions. with this update, you can see it on facebook.

ow i am talking too much.

but i read your comment as a confirmation that the suspend bug, as i call it, is gone. and it seems so, and softube modular acts better than before. strange… or better your comment is a confirmation, i must also read better…

and sorry for scaring you,: i must try to write more clearly.

Hi Fabio, I was also experiencing this with the ACME Opticom and Black Box HG-2, both from Plugin Alliance. In my case, it would happen on the insert slot. I’m glad it is no longer an issue, the VST3 variant of those plugins is now performing as intended. Thank you!

@zolhof: I don’t know exactly why, but yes, it was particularly easy to repro with e.g. Black Box HG-2. I actually contacted PA to let them know the issue was ours and to be resolved soon, once found out.
Thanks for the confirmation!

@Howl: The audio export issue might have been related to the VST3 suspend bug, yes.
10.5.10 is Mac and PC and the VST3 issue was cross platform, so it applies to both Mac and PC.
And don’t worry, I should have written “scared” or better, use concerned :wink:

On my unplayable song in 10.5.10 (Windows 10), I’ve taken a backup of the project, so I can try and fix it.

The biggest send cuprit (if I remove them one at a time) is Wave Abbey Road Chambers. That takes my CPU from unplayable, 100% redlight territory to around 80% and the song plays through.

(other sends that make no difference if I remove them to the songs playability…
Waves - Reel ADT, sibilance, H delay Stereo
Soundtoys - Little Plate
Eventide - Black hole, H910 dual harmoniser
Arturia - Rev-Plate 140
Plugin Alliance - BX_Townhouse bus compressor

I tried bypassing the sends first, but that made no difference to the average load. I had to pyhsically remove them.

Also. If I leave all the sends in. I have one instance of Superior Drummer 3(C&V kit) and two Kontakt instances (one running NI’s Aliasha Keys, the other Heavyocity’s Vocalise). All the midi is muted, since I rendered in place all the midi, before mixing. Removing these instruments, brings the average CPU load,to just beloe 100%. TAking any one or two of them, doesn’t help, but removing all three does.

Hope that helps?

I am experiencing audio dropouts for many seconds too on Windows 10 (1809), CPU Meter going solid RED, a track that is a bit busy but no issues on v10! I didn’t have this issue on 10.5 either, just now on 10.5.10!
I stop the track when it stops the audio, wait for 5-10 seconds, then I hear the tail end of the track, then I can play back the track, before it repeats!

CPU doesn’t even reach 50% when playing back (Resource Manager) when it hangs, with buffer size up to 512, not gone further up with troubleshooting, but over 512 makes it unbearable to jam along!


Instead of rendering in place all midi I lately always freeze the midi and instrument tracks, that saves a lot of CPU. Also you can keep on recording with very low latencies.
And much easier to unfreeze again to change something in the VSTi or miditrack.
Muting a track does not save CPU, de vst instrument stays active.
I even freeze audiotracks when my CPU goesd to the max, so heavy plugins do not count into the CPU.
It’s so easy and fast to do, and just as easy and fast to unfreeze again if you want to change settings in an insert plugin f.e.

@rollasoc and SoundOf: your issues sound more like a performance issue than the problem with VST3 abnormal CPU usage.
Easy test: load a problematic project and disable the “Suspend VST3 Plugin Processing when no audio signal is received” preference in Cubase - if the CPU load is not immediately and heavily reduced (between 50% and 100% reduction), then it’s something different.

I’d recommend to check out the trouble-shooting guide, check if the project’s layout has a role (check different plugins distribution, check that there is no heavy multi-timbral VSTi routed to a heavily processed group, etc.) and please open a separate thread in case the issue persists.

PA released an update of all plugins this morning.

Quick answer to questions

  1. @ca-booter I should have mentioned, that I had frozen all audio tracks with inserts on. It didn’t make a difference to the average CPU maxing out.
    I used to freeze all my tracks, but stopped about 5 years ago, when I went to remix an old song, only to find the VSTi I was using no longer ran, so rendering in place meant I had a proper copy of the sound output, as opposed to the freeze audio file, which wouldn’t always line up correctly.

2)@Fabio Bartolini when the message on the forum said about disabling the VST3 processing, in the middle of January, I had disabled it then. I have other songs that play fine in 9.5 and will not play in 10.5.

My writing partner skipped ten and went from 9.5 to 10.5. He has gone back to 9.5 to mix our next EP, since some of the songs he was happily mixing in 9.5, max out in 10.5.

In my current track, it was mixable and playable in 10.5.0 and is unplayable in 10.5.10.

Nothing my side has changed other than me upgrading Cubase.

So I can only conclude that 10.5.10 is performing much worse than 9.5 (and slightly worse than 10.5.0). I have no explanation why, other than having several songs, that will no longer play.

I’ve tried turrning on/off / different setting for ASIO guard, I’ve tried turning on / off the Steinberg Power Scheme. I still have some things mentioned on VI-control to try.

Update - I have un frozen all the channels with inserts and removed all the insert plugins (except the 8 send channels). Average CPU load is around 50 - 60%. Remove the sends and it drops below 10%. The biggest drop for Waves Abbey road chambers. Confused as to why removing the frozen inserts makes a difference…

This is a small project. 17 audio channels, into 9 groups (42 plugins in total for channels and groups), using 8 Sends (with 9 plugins).

So yes, this doesn’t seem to be a VST issue, just a dropoff in general performance off the application as a whole.

I will keep investigating.

I used win10, I bought a new computer amd3970x, but I can’t play the previous Cubase project, because the CPU is overloaded.

But curiously, cubase8.5 is OK, 9.5 + 10.0 + 10.5 are overloaded.

Because the single core of cubase10.5 is too much, I can’t play the sound in the project.

At this time, I disabled a group of CPU cores with strong single core occupation (8 cores are disabled) to 24 cores, and the CPU occupation decreased.

In cubase10.5 + 10 + 9.5, when I disable the eight cores of AMD, the resource occupation decreases.

I have detailed test screenshots, but I don’t know how to send them to the engineer. Can I get the engineer’s email?

I agree to use exported WAV files for keeping after a song is finished, I do the same. But not while working on the project, then I always use the Freeze function , to me that is a faster approach for re-editing.
I also use Abbey Road chambers and Plates, they are very heavy on the CPU, so I use them very little, or again, freezing.
But I must say that I cannot see any difference in a couple of projects between the last update CPU consumption and before.
My own experience with CPU spikes or high usage in the past was with Graphics Cards(or its drivers), or the occassional plugin.