10.5.10 - VST3 abnormal CPU consumption fixed?

I am running Windows 7 (yes I know it’s not supported but it works) and the last Cubase 10.5.40 update is also causing CPU issues to me.

A project that runs normally in Cubase 10.5 starts crackling very annoyingly after the update.

So I downgraded to 10.5. With all of its errors, Cubase 10.5 is rock solid to make music in Windows 7.

I discoverd the following:
While everything was fine with 10.5.0 something happens now with 10.5.10.
I haven’t any issues with VST3 but now with the update which should cure the issue with VST3s I have.
A project has spikes as crazy and I couldn’t work with it until I activated “Verzögerungsausgleich einschränken” (Reduce latency compensation?). So I deactivated all plugs with latency by pressing alt with Bypass on the plugin slot and the project runs fine . Activating the plugins step by step I encountered sonible’s frei:raum wich was involved in this issue. Only workaround is renaming the VST3 to remove it literally and use the frei:raum VST2 DLL. The other sonible plugins (smartEQ2 and proxyimityEQ) work with no hassle as VST3.

Just updated to 10.5.10 from 10.5.5 and now I get continuous cpu spikes even with just one kontakt instrument and no plugin loaded.
Running MacOS.

Quick update. Just installed 10.5.12.

Opened my failing project and it now runs at about 85 - 90% average CPU. So at least it plays. It even plays at 95% if I drop ASIO guard down to low.
So that is an improvement. Thank you!!

Is the project running at 85-90% the one you described above? Would you send it to me please along with the computer specs? (I don’t need any audio, just the cpr file to see the layout and the plugins loaded)

My main test project (a 2018 mix project, audio only) runs at 40% on a Mac Mini 6x3.2 and at 20% on the Ryzen 3700X PC, but I’m using 60 audio tracks into 20 groups and 4 FX with 148 plugins, so either there is something very heavy being used on your side or perhaps some heavy tracks all routed to a heavy processed group (?!). Looks way too high for that load, even at very low latency.

With 10.5.12 my issue is gone and I can use frei:raum as VST3 again.

I had to go back to 10.0.50 by popping my W7 drive back in my computer. The same basic setup song with the same ASIO settings runs below around 15% with the real time peak barely hitting the 25% line. In W10 the peaks are in the red and the average load is just over 25%. Im running on UAD Capitol Reverb as a send FX.

Needs an update to fix this or if you can make the new upgrades W7 compatible until this is fixed?

@Fabio, maybe you should update the test project.
I have an i9 7900X and a project like:
1x Groove Agent (5 pads/ind. outs), some FX on the drums bus (FF compressor etc, nothing special)
2x Diva not fed into a bus, directly to stereo out.

With this already ASIO meter is at 50%. If I now insert only one instance of new Multitap Delay (preset House Chord Machine), ASIO meter goes to 80% right away (back to 50 if I disable the multitap) and have lots of dropouts/crackling

Asio Guard is Highest, RME newest drivers with 512 buffer size.
Latest 10.5.12 update.

Cubase is barely usable anymore these days…