10.5 Expression Maps no longer retained

Hi Steinbergers,

Tracks that are saved as Track Archive XML files no longer retain their Expression Map information anymore when imported and enabled again.
This is a critical feature and worked in 10.0.50 and previous versions.

Here are the steps:

1 - Create a new empty Cubase project.

2 - Create an instrument track.

3 - Create and assign an Expression Map to the track.

4 - Save the track as Track Archive (File > Export > Selected Tracks [It does not matter if Copy or Reference media files are selected or the new compatibility box is checked or not]).

5 - Close the project.

6 - Create another new empty Cubase project.

7 - Import the Track Archive file into the project.

- Result: The Expression Map is gone.

The same is true regardless of the track being disabled or enabled before the export. I normally save (prior to 10.5) many tracks at once in a disabled state and all Expression Maps are restored.

This was not the case in earlier versions and is an integral part of my workflow.
For now, I am forced to continue to work with 10.0.50.

I hope that this is an easy fix and you can include it in the next maintenance update.

Thank you all at Steinberg for your great work with 10.5.


Are you sure this was working in C10.0.50?

Yes, Martin, I’m absolutely sure.

I’m using it every day in C10.0.50. I’ve created a whole XML library (Track Archive) for my modular template, consisting of disabled Instrument Track sections that I import into new compositions while arranging or orchestrating. That’s the reason why I cannot use C10.5.0 for now until this is fixed.

FYI, it’s also working in C9.5.50.

That’s a good opinion. Also, in my case, the expression map does not function normally as it triggers. During playback, the expression map is randomly initialized and sound gets messed up.

Yes, using Kontakt the expression map articulation changes randomly now, disregarding what I have filled in. This didn’t happen in Cubase 10. This is obviously real bad for work flow!

Martin, were you able to confirm this bug?


Yes, I can reproduce it. Reported to Steinberg CAN-772.

Thank you Martin.

I’m totally lost, upgraded to 10.5 and all my expression maps don’t show up from Track Archives, like Profezeus says

For me this is a total deal-breaker. I only load sounds from the track archives and have dozens of collections for all kinds of templates. I recently loaded back all the expression maps, and then saved a huge song project (all disabled) just to have something I could use to get back the expression maps, but then I have to start everything with that huge song project instead of just loading whatever I need when I need it.

The track archives is a key feature for me, it loads sounds that are tweaked in every way, volume, panning, CC assignment, grouping, folder, fx, sends, inserts, and so on. But to lose Expression Maps makes Cubase now impossible for me to use.

Should I go back to an earlier version, or is this now fixed?


As I mentioned, this has been already reported to Steinberg. So now we can hope in a fix.

So this issue has highlighted the fact that Expression Maps only save in project files, not the program (which I mistakenly put myself under the impression they did). So not only are they not currently recalled with track archives they are not available in project files that don’t have them saved within already. And there doesn’t seem to be a way to copy them to a different project file or import them in bulk, unless I’m missing something. Maybe the Profiles feature will do it? Searching for these issues or capabilities with expression maps hasn’t wielded any results for me. Thanks!


Could you write step by step use case, please? What was working in the previous Cubase version and doesn’t work anymore, please? I mean the project file case.

This definitely is a critical feature, and i just today came across. But yeah, it has been fixed in the recent update 10.5.20!

BUT! Unfortunately not completely. While it works when there is no Folder Track surrounding your MIDI Tracks - it is still broken when there is one. The annoying thing is, my template workflow depends on folders (surprise…).

I have exported two Track Archives, with the only difference in one being in a folder, the other one not, see attached image.

So i went today from super annoyed to super happy and back again to total desaster! My Template Workflow simply doesnt work anymore…

1 Like

I did some more tests, found a workaround, and maybe some clues to where this issue might come from. The screenshot shows three cases:

Midi Track inside of a Test Folder
Midi Track outside of a Test Folder
Midi Track duplicated so there is one inside and one outside of the Folder

These Tracks have been exported as Track Archive and the screenshot shows the reimport processes and their result. The third one is my workaround, I only have to delete the duplicated tracks after the import. I prefer this over the second method, as i can import the folder and its name & color and do not have to move tracks around (which sometimes gives weird results, in my real case screnario i have some track instruments alongside the MIDI tracks in these folders).

Of course i can provide the track archives as files if wanted, but at the moment i cannot upload them to the forum (I think?)

I have done some examination of the XML files. The Expression Maps are definitely saved within all three variations! What gets lost is only the assignment to the correct MIDI track. So hopefully it is not a long way left to go (at least for this problem, there are some more, but these are a different story and I managed to get around them by editing the XML FIiles manually).

Thanks for your attention!

Ok Its 2021 April 4th → Cubase 11 on Windows → Regarding folders and Expression Map still the same problem when trying to import tracks that are inside a folder from another project into a new project.

All the Tracks that have expression maps and are inside a folder do not get imported with the expression map inside a new project. I don’t know if this problem still exists with Track Archives XML Imports in Cubase 11 …

Could anybody tell me the CAN number if this problem has been addressed.
Thanks, lokotus

1 Like

just bumping this, out of solidarity, hoping that Cubase 12 will have this issue solved.


Reported to Steinberg. Please see this thread. Thank you.