10.5 New Retrospective Record emptying after 30 seconds: anyone wishes for an option to customize this?

Hi all,
I Just thought I’d gather opinions here:
The new Retrospective is great in all senses, I just find it problematic on one aspect:
In Stop Mode: After you have played and there is no further data coming in for 30 seconds and then another new MIDI event is received, buffer is flushed.
When using Retrospective for sketching, it’s very easy to improvise, stop thinking for 30+ secs, then hit a midi note only to realize you’ve lost the previous buffer.
It’d be nice to be able to revert to the old behavior where Retrospective stayed “listening” all the time in Stop mode until Transport is operated.
I know it sounds picky but the old behaviour saved a lot of good ideas for me until 10.0
Any thoughts on this?

I agree 100%, just had not noticed it yet, but would be a dealbreaker almost. Retrospective record should be stress free!

Let’s hope we can get an option soon, glad I’m seeing people think alike on this!

I’m still on 10.0.50, but well… IMO, it’s not ‘picky’ at all : why on earth do we have to see these kind of regressions coming out of nowhere in every updates ? And probably more important : why has this new limitation been done for ? :confused: Seriously…
As I have often started projects in the past thanks to Cubase retrospective record implementation, I’m less prone to make the 10.5.x update, seeing this kind of thing. So, waiting to have more precisions concerning this new ‘feature’… :unamused:

+1

I can’t even find where to enable this…I’ve watched videos, searched, read. Was it removed or am I having a senior moment?

Cubase 10.5 Pro

https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/recording/recording_recovering_midi_recordings_c.html?hl=retrospective%2Crecord

Cubase 10

https://steinberg.help/cubase_pro/v10/en/cubase_nuendo/topics/recording/recording_enabling_retrospective_record_t.html?hl=retrospective%2Crecord

I know the topics are slightly different but I could not find “Enabling Retrospective record” for 10.5

Prefs/Record/Midi/Retrospective Record Buffer Size I think

To Enable/disable, RIGHT click on the Transport Start button and it will be there in the list

This is a pretty frustrating problem, still experiencing it in Cubase 11. I hope this has been fixed in 12.

They fixed the bulk of issues I had with it before and introduced a more limiting issue in the process. Why is there a setting to change the max size of the buffer but not the time before it is emptied?

Very helpful feature overall, just sucks to lose a fundamental aspect of what makes it useful. I’d personally take the old retrospective MIDI record functionality over this one.

This is where having clip launching comes in handy. You pick several “channels” of clips with longer spans, say 64 measures even, then hit record, and just groove to it. It’s like jamming with yourself. You could do this with cycle record, and track versions, or even setting up independent track loops, or using the arranger, and copying cycles. All 3 of these options are cumbersome and being able to select which clips are running from a grid controller is so much more intuitive. Especially since you can change it up, while grooving.

I do this very easily now with Sampler tracks, and some MIDI trickery.

This is NOT the same thing as loop based “production”.