10.5 Something is (definitely maybe) broken in the logical editor

If I use the same command with a shortcut it behaves different than the apply button in the editor. In 10.40 it works the same and as expected.
I rely on this workflow, so this ain’t working

See attached screen recording (GIF)

https://drive.google.com/open?id=123PEQrr-dHf1qS0YpF6VB2flcF2JHU6b

Hi,

Actually I’m wondering that you get any result. Shouldn’t there be Or instead of And at the end of the all lines with the name? And shouldn’t there be a parentheses around all names lines?

My expectation is, you want to search for the tracks where the name contains Genelec OR the tracks tracks where the name contains Instr, etc. Not the tracks, where the name contains Genelec AND Instr AND etc.

Am I wrong?

As far as the logic goes, it’s fine: do the operation on all tracks whose name doesn’t contain xxx, and also doesn’t contain yyy, and also doesn’t contain zzz.

As far as why it works differently when invoked via keystroke, I did a short test and the PLE hid the requisite tracks, and, it worked the same upon clicking Apply, or upon invoking the preset via a keystroke.

Please post a text read out or static image of your PLE preset, the animated gif is impossible to pause or rewind to review what’s actually going on, so I might have missed something. Videos and gifs make for poor testimony when reporting bugs. Written out reproduction sequences are better since they limit the tester’s actions to the issue only.

Thanks for looking into this.

I solved it by doing a complete uninstall of 10.4. and 10.5 with Appcleaner (Mac) and a clean install of 10.5 with selectively copy and pasting the preference files back. It now works as expected. Could be Metagrid related….

I will post a more comprehensive written out procedure next time I encounter unexpected behaviour.