10.5 - Tempo edit field - not accessible by shortcut as expected

Hi, Cubasers and Developers!

Shift+T (shortcut for Edit Tempo) doesn’t activate Edit field for tempo. Contrary to expectations, it somehow freezes and whole Cubase loses the control - if opened Key Editor, notes cannot be selected, buttons don’t react and all seems that everything I do in Key Editor, affects Project window until I switch to Project window and click in Tempo edit field and press Enter to exit from it - then all becomes normal again.

  1. New project
  2. Add instrument, record some notes, click on part to open Key Editor.
  3. Switch to Project Window and press Shift+T (in C 10.0 it activates edit field for tempo on bottom transport bar), but here nothing happens.
  4. other points for your taste… nothing’s working until you doubleclick on Tempo edit field and press Enter to exit from it.


The Enter Tempo (Shift+T) function works in the Tempo Editor only.

It is well documented change between 10.0 and 10.5 ?
And is the freezing Cubase also a necessary option in our workflow? Can you spend a little minute to take our issues serous? I don’t play newbie games here. I can use Cubase 10.0.50 without problems and don’t come here. Is that your target?

Now serious…
Yes, Shift+T in Tempo editor opens a small form for entering a tempo and signature. Okay.
The same happens in Key editor - pressing Shift+T opens the same small form.
So why it doesn’t show in Project window? In C 10.0 the same key command activates Tempo field in Transport zone. I use this often.


I had a look to the issue once again. You are right, the Tempo field doesn’t open in Cubase 10.5, when you trigger the command from Project window.

This has been reported to Steinberg already CAN-25446.

Thank you very much.