10.5 update crashes my mac pro????

hello. i have been using cubase 10.0 on my mac pro 12 core for the last year. OS hi siera.

last week i upgraded to cubase10.5 . the licence dongle shows the 10.5 licence as being activated and i installed and ran the latest version of e licencer control center. i also performed the recomended maintenance procedure.

that all seems to work just fine. and the synchrosoft center says that everything is ok.

howerver C10.5 locks up with an error every time and wont boot.

even worse C10 is also refusing to boot.

i get a message saying Cubase10 and Elements 10 are not authorised.

then it crashes. any ides guys.

thanks in advance, Spaceman

Steinberg doesn’t mention High Sierra as supported OS for Cubase 10.5. Just Mojave and Catalina.
I’m on macOS Catalina and Cubase runs tight and stable on my system.

thanks space cat. i will look into that and see if you are correct.

anyone else working C10.5 on older operating systems.

thanks Spaceman

Yes. Using Mojave. CB 10.5.0 was unusable, CB 10.5.5 is a bit better but still not ready for prime time.
10.0.50 is my daily driver.
End of the month, 10.5.10 will be here. We’ll see.

yes your right. seems Hi Siera users cant go to 10.5

sad state of events.

10.5 is completely broken on Mac. Use 10.04 until update comes end of Jan.

can any one please report if they are running Cubase 10.5 sucessfully on Hi Sierra?

thanks spaceman

it is now 10 days since i submitted a ticket with cubase support but i have not had anything back from them. is this normal?

how long does it take before someone from support comes to help?


I don’t think this is a cubase 10.5 - High Sierra problem.
The first time I notice this problem was on Cubase 9 and OSX 10.9. The Mac says randomly “no license found” on Cubase start.
I change the USB Port. This helps for a wile. Than I bought a new USB Hub and the problem was decently gone.
Last year I update my Mac to High Sierra and Cubase 10 and got the problem again.
It seams it helps to change the USB port for the Dongle, but I could’t find a real solution for it.
It looks like there are too many requests at a short time on the Dongle and this crashes the Elicenser driver or the Dongle itself.

Since 10.5 I’ve had odd problems with my elicenser; sometimes saying ‘no licence for xxx’ which can only be solved by force quitting and sometimes Cubase opens saying Cubase 10.5 Artist (I have 10.5 Pro) which can be remedied by closing and restarting. I’ve never had these kind of issues before 10.5, although to be fair I’m trying to9 run this on Catalina.


e licenser software is jacked simple as that fellas.

Im running HS with 10.0.50 as well as 10.5. 10.5 WAY less of course since it has MANY issues

I get those Artist not installed BS messages as well even with a new DONGLE and a COMPLETE OSX Re Install!!. Its the licenser software simple as that.

Steps I have taken to FIX e licenser app errors:

  1. Bought NEW Dongle
  2. Re -Installed my OSX from scratch


  1. Run the latest e licenser installer and UNINSTALL the application
  2. Re install the latest e licenser
  3. Re boot your Mac doing the Command+Option+P+R
  4. Open e licenser app and run maintenance
  5. DELETE the e licenser app PREFS file

Good luck. IMO this is a PROGRAMMING ERROR

Sound advice IMO

wow, this is very bad news. at the moment I can not boot either Cubase Pro 10 or Wavelab Pro 10.

support are suggesting the physical eLicenser (dongle) is the issue, but in the eLicence Control program is showing that the dongle is 100% correct.

I have also upgraded to the latest eLicenser software, so I don’t understand whats going on.

lets keep each other informed please.

thanks Spaceman

I don’t believe it is an really an hardware problem, because I got this problem 3 times and alway after an Cubase update and the including eLicenser software.
The update are Cubase 9, 10, 10.5 and it was on 3 different Mac Pros.

yes i agree with you. when i went from C5 to C9, ny Mac also wouldnt read the licence.

from what im gathering there is a specific version of eLicenser that will work corectly for any specific Mac.

which version of eLicenser depends on the Mac model and Mac OS.

so just upgrading to the latest eLicense doesnt work if you dont have the latest Mac and O/S system.


I once also had massive problems with the eLicenser and tried a lot of things to get it back working. At the end I solved the problem with buying a new dongle. Mine was a very old one, which was causing the problems. Since than no one issue again (knocking on wood).

was the same for me, software showing all fine, but nevertheless it was the hardware
“support are suggesting the physical eLicenser (dongle) is the issue, but in the eLicence Control program is showing that the dongle is 100% correct.”

hi Bigsound.

after reading your post i decided to eliminate the problem of a faulty dongle. i bought a brand new one.

before i installed the software it was suggested by steinberg support that i reverty to an older version of eLicense Control.

for my mac running Hi Sierra 10.13 they recomended eLicencer which is an older version (definately not the latest recomended version)


before installing 4257 i had to uninstall all later version.

after installing eLicenser and after transfering the licences across to the new dongle, my system is now working again with Cubase 10.

i wont bother with C10.5 as its not Hi Sierra compatable.

so i guess that either the dongle or the Elicencer version were to blame for the fault, but i am not sure which. i will post back if it keeps working.

i hope this thread assists someone else, fighting the same issues.


Hi Spaceman, nice to see everything’s working out for you again.

wasn’t sure about the system requirements, so I did a search. Found several here in the forum running 10.5 on HS and even Sierra without a problem. Maybe you just try it again. You can install 10.5 besides 10.

I am having major issues with 10.5 as late as July 2021. No sound at all now for 4 days and occasionally flickering track and bus levels. OS High Sierra. Spooky. Any suggestions. I am downloading the older version 10.0.05 as I type. Anything else to be aware of?

I’m on a MBP, High Sierra 10.16.6 - Cubase
No real problems to report other than a lot more sluggish than my other volume; same computer running Yosemite and Cubase 8.
So, other than being much more of a resource hog I’m able to work.