100% CPU Usage when mixdown

Just ran a test on my system. Here are the results. Song was 13 tracks a little over 6 minutes long. It took a little over 1 minute to export. Using version 12.0.40


Don’t know how, here it happens on 2 different PCs. I suppose the slowdown comes together with the high CPU usage. I am trying to reproduce it tomorrow with a smaller project, so I can share that one with you and maybe we can find togerher what is causing the issue.

Reading again about these issues with no SB statement at all, I will not make any advantage of the current sale which’d give me Cubase 12 Pro for 60 EURO. I need a working product and not a discount.

1 Like

I tested C11 vs C12 today again, to see if C12 has some issue with any plugin or sth like that. And I found out that it does not have anything to do with:

  • 3rd party plugins (disabled all of them)
  • events in the project (deleted all of them)
  • with frozen tracks (unfroze them)
  • audio tracks with offline processing/variaudio/etc. (deleted all of them step by step)
  • reinstalling Cubase12 (uninstalled C12 and reinstalled it)
  • Preferences (trashed the entire Steinberg folder in C:\Users\user\roaming\Steinberg)

The mixdown time and the CPU usage on C12 is always doubled compared to C11, everything else being the same (buffer size, etc.).

Even an empty project goes up to 100% CPU. The interesting thing is, that there the mixdown time on C12 is comparable to C11, but as soon as you add more tracks and plugins, it gets worse and worse.

4 Likes

Hi @Tj99 !

I’ve just run a series of tests with an effectively empty project, but could not find an appreciable difference in Audio Mixdown Export elapsed time except that on my system Cubase 12 used a lot less average CPU than Cubase 11 (rather than more). Cubase 12 in low 40s % and Cubase in the low 70s %.

Here’s my project folder used for both Cubase 11 and 12:
RenderTest.zip (2.0 MB)

And here are more details of my test project, my system and my test results:


Project Settings

Record File Format 44.1KHz 24bit Wave

120bpm

Time between left and right locator:
18:00 minutes

1 Empty Audio Track
Stereo

Audio Mixdown Export Settings

Exported Channel: Stereo Out
44.1KHz - 16bit Interleaved Wave file
Real Time Export: NO

TEST RESULTS:

CPU utilization:

before Export Audio:

Cubase 11.0.41: about 5% overall
Cubase 12.0.40: about 5% overall

during Export Audio:
Cubase 11.0.41: about 71% - 76% overall - but 100% for Core 0 Thread 0
Cubase 12.0.40: about 40% - 45% overall - but 100% for Core0 Thread 0

Elapsed Time for Export:

Cubase 11.0.41: about 24 seconds
Cubase 12.0.40: about 23 seconds

System Specs:

CPU: Intel Core i7-4930K (3rd gen) Ivy Bridge-E 3.4GHz - Turbo (while running Cubase): 3.8GHz
MoBo: ASUS X79 Deluxe https://www.asus.com/Motherboards/X79DELUXE/specifications/ BIOS 4805 installed on 2018-10-11
RAM: 48GB
Graphics: NVIDIA GeForce RTX 2060 SUPER

Tests performed with Project and Export on spinning rust SATA3 RAID0 as well as on NVMe SSD with sub second (difficult to precisely measure) differences.

Stopwatch used manually: Clock app on mobile device

1 Like

Hey @Nico5
I think I found the issue.
thank you very very much for your help!

I tested this project on my side, and to my surprise I had in C12 a CPU usage of about 44% average on mixdown and the elapsed time was about 10 seconds.
I then created the exact same project from scratch and had the 100% usage again and an elapsed time of about 14 seconds.

The only difference I noticed was the sample rate and that seems to be the cause of the issue in C12.
If the project sample rate differs from the mixdown sample rate, all cores go on full load and the export time is multiplied.
Thats probably why some have the issue and some not. Those who work with the same format in their project as the mixdown format, wont have any issues.

Can you please try to set your project settings to 48kHz and retry to mixdown a 44.1 kHz file?


2 Likes

Here the same project I tested in post #19 with different sample rates to illustrate the issue. Look at the CPU usage and estimated time difference of the upper and lower right pictures.


2 Likes

@Tj99 great finding! it behave the same way here! so the culprit is the down/up sampling?

48khz to 48khz

48khz to 44khz

2 Likes

Yep! but only on C12. They probably tried to make mixdown more efficient and accidentally screwed up the part, where you’re mixing down to other sample rates.

1 Like

Great detective work!!!

Mismatched sample rates gave me the 100% CPU on C12, too!

Mismatched Sample Rate Test Results

  • Cubase 12.0.40 (Project 48KHz 24bit; Export 44KHz 16bit ):
    • 28 seconds; 100% CPU, 100% CPU on all 12 threads across 6 cores
  • Cubase 11.0.41 (Project 48KHz 24bit; Export 44KHz 16bit ):
    • 29 seconds; 65-75% CPU, 100% CPU only on thread 0 on core 0;

Cubase Project Folder: RenderTest-02.zip (1.1 MB)

Test Environment:

Project Settings

Record File Format 44.1KHz 24bit Wave

120bpm

Time between left and right locator:
18:00 minutes

1 Empty Audio Track
Stereo

Audio Mixdown Export Settings

Exported Channel: Stereo Out
44.1KHz - 16bit Interleaved Wave file
Real Time Export: NO

System Specs:

CPU: Intel Core i7-4930K (3rd gen) Ivy Bridge-E 3.4GHz - Turbo (while running Cubase): 3.8GHz
MoBo: ASUS X79 Deluxe BIOS 4805 installed on 2018-10-11
RAM: 48GB
Graphics: NVIDIA GeForce RTX 2060 SUPER

1 Like

Using Nico5’s test project same result here on Cubase 12.

2 Likes

Good that we could find the culprit!
Now hopefully SB will recognize it as soon as possible and add it to the next Maintenance update.

The thing is, with an empty project the export time is atleast the same, more or less. But try to export a finished mix, it will take double the time and more.

1 Like

@Martin.Jirsak can you report that to the Devs perhaps?

Thank you!

For know the solution is mixdown to your session sample rates and convert to desired sample rates using 3rd party software such as Voxengo r8brain to avoid your cpu usage hit 100% during mixdown.

Good find. I saw this note after doing some testing on my system yesterday while doing a mix because I had not been paying attention to CPU usage while exporting, but it had seemed to me that mixes were taking longer than I’d remembered with Cubase 11 (I had not gone back to Cubase 11 to test since, despite issues I’ve encountered, I have been using Cubase 12 consistently in my projects since 12.0.0, and I’ve updated consistently when the maintenance releases come out).

My projects are generally at 96 kHz, but the most common exports I do, due to doing multiple mixes in the course of getting to a final mix, are for 44.1 kHz, with both a WAV file (for listening on multiple devices) and a 320 kbps MP3 file (for car listening tests as my car will only play MP3 files, not WAV). So yesterday I was doing this sort of mixdown, and I took snapshots of Task Manager’s performance tab and processes tab during the export:

After that, I went back to the project and, for comparison, took similar screen shots when the project was actually playing back:

Mind you, I was not clear that this was necessarily a problem. In particular, I do not use real time exporting, so, the system could be doing more work to try to get a mix done faster than it could in real time (and my system is far from state-of-the-art – I think I built it in 2014). But it was interesting to observe the difference. And I actually wish it could use more of the CPU power to avoid glitches (and/or dropouts) on playing back the project. (While this project was not dropping out at this point, I’d done a lot of rendering submixes to audio to prevent that, but most times I’ve noticed dropouts and other glitches CPU use is not maxed out.)

Same here, I just noticed it, because exporting really took way longer than in the past and my PC was running like a jet fighter.

Look at your single core performance. Usually when having glitches and drop outs the 1. CPU is maxed out, even if the overall CPU usage is about 50%. At least its the case here. I am running Cubase on a 5 year old system (i7 8700k) and I don’t have any issues of this kind, until my CPU1 goes up to 100%. In that case the overall usage shows around 45-55%.

But thanks for trying to reproduce the issue on your system.

2 Likes

My PC is only an i7 5820k (3.30 GHz, 6 cores, 12 total threads). It’s been a while since I’ve looked into this issue, using all the usual tools like LatencyMon, so I don’t think I’ve checked what is happening with Cubase 12 on this front. However, my recollection from a long period of troubleshooting this issue (both on SONAR and then Cubase) was that none of the CPUs seemed to be maxing out. I’d even been looking into it at one point with the main Cakewalk developer, supplying him all kinds of detailed information (they have lots of configuration options that optimize things in different ways), but ultimately it was a mystery.

My main suspicion (partly from LatencyMon results) had been something to do with my Nvidia video card, but I’d also tried a bunch of things on that front (though not any other video cards), and I’ve also tried many other system optimizations over time, some which seemed to help (in some cases only temporarily) and some that didn’t make a difference or made things worse. It could also be just a combination of things on my system, which cannot be a dedicated DAW.

At this point, I’m mostly just learning to live with it (i.e. with workarounds like the aforementioned submix renders, freezing instruments with FX, etc.) until such time as I can afford to do a significant PC upgrade.

1 Like

So, is this reported to Steinberg already? If not it may never come to their attention because the forum topics are not always looked at. If someone with a C12 license could open an official support ticket (as I used to do it for all of my findings)? Thanks a lot!

I did already and posted all the details I posted here in this thread!

1 Like

Unfortunately, I cant create a support ticket because Im in Malaysia and the website ask me to contact our distributor here directly. I really dont undestand why they would do such thing. Is there any way else. Would they entertain an email?