12 won't run if Activation Manager is down?

Well - I took a chance on 12. Had it sort of going for a little bit after removing videoengine.dll.
But now when it checks for a license, it says no valid license found.

So I went to the Activation Manager and it just hangs.
I guess it’s because it’s a ‘cloud’ thing or something?
The usb licenser seemed a lot more reliable even though it’s a hassle.

So…it’s back to 11 for a while, I guess. They got my money anyways.

Got exactly the same … After activation of the license, it worked 2 min, then it crashed and since then, “no valid license found” message prevents Cubase to launch …

I thought maybe there was a problem with the Activation manager, so I tried to reinstall it and got this:

Mmmh, turns out that rebooting my computer solved my issue. Strange… Hope it’s just beacuse it’s my first attempt to use the new release :slight_smile:

OK - I’m going to try a reboot.

Got no such problem on my side. the activation manager was installed silently with the application

The Activation Manager was fine earlier, but stopped responding.

Anyways - after a reboot and removing the videoengine.dll again, all seems to be working.

It’s showing a lot of missing content, but I have the Steinberg Absolute collection on a usb stick,
so that’s to be expected, I guess.