16 bits export just as big as 24 bits when replacing

Alright, picture this: your mix is done. You export your mix as 24 bits. Then you realize the client wants 16 bits. So you export as 16 bits, replacing the original file. You look at the size: it hasn’t gotten smaller. It’s exactly the same size as it would be as a 24 bits file. Huh?

Then you export your mix again, this time naming it differently, but still 16 bits. The new file is smaller, as it should be.

What’s up?

Martijn.

No one care to reproduce? Could be just Mac.

What if you reimport the file? What does the header say?
16 or 24 bit?

Fredo

  1. It says 16 in Nuendo, Quicktime and the Finder. But the size is 1.5 times what it should be. Have you tried it?

Is there anyone who could reproduce this behavior? Maybe we can confirm this a s a bug…

Just a guess but I imagine this is a mac os thing. The replace function my leave the current file blocks still allocated to the drive even though they are now zeros.

What happens if you copy the strange 16 file to another drive. Does it shrink?

Just a guess as I say.

Hi, thanks for replying.

I tried copying to a different disk, but the file stays the same size.

You’re on Mac, right? Would you be willing to try and reproduce this anomaly? I’m curious if it’s just my computer or all Macs or Mac as well as PC.

Best regards,

Martijn.

No one?

Cannot repro this on XP SP3.

Thanks for reporting. I can imagine it’s Mac only. Are there any Mac users out there that want to give it a whirl?

Is the file renamed or does it have the same name as the previous version?

I’ve encountered instances where OSX has played back the wrong mp3 file simply because the new one had the same name as the old. This was a few years ago of course, but could it be something similar in that it reports the size of the old file? Perhaps you could try it but giving the new file a different name.

Well, it goes like this:

I use Export Audio Mixdown and create a file named Mix_01.wav. 24 Bits.

Then I change my mind and use Audio Mixdown again, this time changing 24 bits to 16 (either after using a dither plugin or just truncating, the result is the same). I hit ‘Export’, after which Nuendo asks: Overwrite? I say yes and the new file is written over the old one.

The new file thus has the same name as the original and is indeed 16 bits. The size, however is 1.5 x what it should be. And since there is only 1 file, there is no chance of playing back the wrong file.

Like I said earlier, if I give the file a new name (Mix_02.wav) before exporting it as 16 bits, the file size is correct. I just want to be able to overwrite a file that has the wrong format.

It is only recently that I noticed that the file size is incorrect. I installed Mountain Lion the other day, so that could be part of the problem. Now I think about it, I should try using a different application and do the same thing. Maybe I will. I’ll report back…

Hey Martijn,

I’m on a Mac 10.7.4, Nuendo 5.5.4

I just exported a 24bit mix, then re-exported/replace with setting @ 16bit. All worked as expected. The resulting ‘replaced’ file showed up as 16bits after the 2nd bounce/replace.

That being said, I had problems with the ‘replace’ functionality a little while back (5.5.2? 5.5.3?). At the time I didn’t notice your 24bit/16bit issue, but I was ending up with corrupted files. At that point I started creating new files instead
of ‘replacing’.

Best,
Jeff

Hi Jeff,

Thanks for testing and replying!

You said that everything went as expected. Is the file size as small as it should be? Because my resulting file, even though it shows up as 16 bit, is as big as a 24 bit file.

Thanks,

Martijn.

I just tried to duplicate on my Mac, and everything worked the way it should.

It sounds like you may be having disk directory issues-- have you run DiskWarrior or fixed your permissions lately? Run a maintenance utility?

Good luck!

Chewy

edit based on your question to Jeff above, 24-bit file= 8.1 M; 16-bit= 5.3 M.

Hi Chewy,

Weird. Are you running 10.8.2 as well? Because it started after upgrading from Lion.

Permissions are fixed on a regular basis. Maintenance utility no.

Thanks for chiming in.

Martijn.

Naw, I’m still on 10.7.

Strongly recommend DiskWarrior and Onyx-- running them every month or so really knocks out the little unexplainable OS glitches that pop up every now and then.

Chewy

Ok, I’m sorry if I missed the part in bold earlier, but just to reiterate though:

Are you sure the actual file ends up actually being larger than it says, rather than just being reported by the OS as being larger?

It sounds very close to the problem I encountered with mp3’s a while ago…

Hi Martijn,

I just checked again and the 16bit file was the same size as the 24bit. I copied them both to another drive and the size info remained the same.

Jeff

Well, that ain’t right. That’s exactly what I’m talking about.

I ran some more tests:

Nuendo 5.1 does the same thing as 5.5.4.

Using Quicktime, however, the file does get smaller when overwriting a 24 bit file.

Interesting…

Martijn.