[2.0.11 / 2.0.12] VST Live Sync with Cubase Pro 13 is completely unusable

I have just updated to VST Live 2 and am disappointed because of the following problem.

The major VST Live MTC issues fixed in version 1 do not appear to be integrated into version 2. In fact, it seems to be worse than ever since MTC was released in VST Live. Cubase hangs a lot when External Synchronization is set (Cubase is in Slave mode).

I have compared v1.4.70 with 2.0.10 and 2.0.11.
1.4.70 is quite good in syncing with Cubase Pro whereas 2.0.11 is totally crap in this case. Doesn’t matter if FlexLoop is activated or not.

Here are 2 videos:

  1. Version 2.0.11

  2. Version 1.4.70

Check and try to change the “MTC Follows Cursor” Preference (Studio Tab).

Hi @musicullum

Thanks for your response. There is only a Studio tab in Cubase, but there is nothing corresponding to the MTC Follows Cursor. There is project synchronization setup in the Transport tab. External Sync is activated (see video below).

There is a setting “MTC Follows Cursor” in VST Live Preference. And here is the problem, as soon as it is activated, the sync in Cubase goes crazy - stops and starts irregularly.

See this video:

Then deactivate it, no?

When it is deactivated, Cubase runs smoothly, start point of a song is matched properly, but FlexLoop is not working.

But that was the only change we made to MTC output, except for a lesser tolerance when position doesn’t match cursor.
Anyhoo, we reverted the change so that with the upcoming version, it should behave like before.

Great, thank you!

unfortunately with 2.0.12 it’s not better.

  • When in Song 1 a loop is set for the first part (1 measure), Cubase starts the 2nd time of the loop and then runs smoothly:

  • When in Song 1 FlexLoop is deactivated, Cubase start / stop goes crazy:

  • Song 2 without FlexLoop, Cubase start / stop goes crazy:

  • Song2 with FlexLoop, Part 1 (with 1 measure duration), endless loop => Cubase doesn’t start at all:

  • Song2 with FlexLoop, Part 1 looped 2x => Cubase starts late and then stops/starts/stops…:

Tested some other cases, I think I give up. Too hard to explain every case.

MTC should work as before when no Flex loop is involved.
We’ll check MTC for Flex Loops seperately.

Please see this video, no flex loop is set.

same as here

Wow!!! With version 2.0.13 it works perfectly! Even the loops are working with “MTC Follows Cursor”!

Only one thing I’ve figured out - when a loop is set to 8 measures, the loop is not happening, but with 7 or 9 it works. But this is not a problem for me, I just discovered it by chance.

Great work! Thanks a lot :ok_hand:

1 Like

… excellent news!

can you give us some more hints about that one? Which tempo? Tempo Track with multi events? How long the loop. From when to when. Maybe a screenshot about your loop will answer all questions to analyse the problem.

Thank you
Michael.

Weird - just checked again - very specific :sweat_smile: - made some tests with different tempos and durations, in my tests it ONLY didn’t loop in Cubase with the following settings:

  • Tempo: 142
  • Duration: 8
  • Loop: endless or other
  • Frame Rate: 25

Figured out that it works when the frame rate is set to 30.

You can test with new projects in Live and Cubase like shown in the screenshot.

EDIT: Generally, the loop works best at 25 frames. At 30 frames, it often only loops at the 2nd or 3rd time. Therefore I have set it 25 in my project.