[2.0.22] Bug - input routing lost on record tracks for stacks

Hi @musicullum , i’ve been able to identify and reproduce a subtle bug that drove me crazy for weeks … input routing lost in record track from global stacks, when this things happens:

  • i have many songs with 6 record track from global stacks in each song.
  • having no songs layers nor songs stacks (only globals) there is nothing to preload, so no preload songs or parts active.
  • if i then need to change, add or remove some audio connections (not touching the currently routed to the records tracks ones - example and other small bug: i renamed the main out as “out 1-2” and every time i reopen the project it creates another “main” connection that i usually go and delete), the currently loaded song preserve the record traks input routing, but every song in the setlist that i not previously selected loses the input routing to “nd”.
  • to avoid this i selected every song in the setlist prior to change audio connections and this way all record tracks input routing are preserved.

If this is not clear to you, i’ll make a screen record and share to help you understand.

While we are here, as i write earlier, in this project i renamed the main out to another name (the one with the record button in mixer), and i deleted midi in 1 and midi in 2, i only have another midi connection as VM midi 1. But every time i load the project the midi in 1, midi in 2 and a “MAIN” output reappears in connections (the main out created as a normal out not the one with rec button in mixer). Is there a way to avoid it?

Thanks, ciao, Ciro.

There is always something to preload :slight_smile: But I see your point.

Will check.

Would “File/Preload Parts” also do that? That’s exactly what it it supposed to do, so even though there is “nothing to preload”, it should help your case.

The Hub (when opening the application) defines 2 MIDI Inputs, audio device, and MAIN audio output so to assure that those are always present to make the app usabale in the first place. Maybe you can re-configure those to your liking?

Well, i would, but “nothing to preload” is exactly what vstlive tell me if i try to preload something :sweat_smile:

Right, as said, we’ll change the text, for now just ignore it.

Dear @musicullum , it seems regardless of ignoring the text, it keeps doing the “nothing forever. I might be wrong, maybe the animation isn’t showing the progress going under hood

It actually don’t do the preload thing… you can
only cancel the operation, start button is obscured.

shoot…you are correct, will also change for next version, sorry.

Hi @musicullum , now i can manually select preload parts and it will work. Anyway, even if always preload parts is flagged, it will not preload on file opening, i have to do it manually (maybe because nothing to preload is still a check the software make and exclude autoload).

Will it be possible to enable always preload parts even when no assets in parts to preload?

I forget to do it manually and changed again something in audio connections, and bum!! All tracks inputs again on NC… so 6 rec tracks x 23 songs = 138 inputs to manually reroute… again :rofl::rofl::rofl: (ps please let me know if you can reproduce the bug this really need to be tackled down).

Ciao!

Sorry, that happens if you have no Layers, no Stacks, and no Modules. Will be fixed with the next version.

1 Like