2/4 Beaming

I want eight notes to only be beamed together when they fill the beat. I tried changing the notation options but they aren’t perfect.

Version 1 splits the beam in the 3/4 bar which I don’t like because both beats are filled with eight notes.
Version 2 beams across the beat when the beats aren’t full (bars 1-3).
Version 3 is my preference but needs some manual beaming, which I would like to avoid.

Is this currently possible? If not, could this be implemented?

Isn’t this combination of settings what you’re after?


If I may, if that combination works, I might think that the pictures are misleading (especially the third one…). But I’d be glad to know if that covers the OP’s needs.

Not quite. The options you showed are what I used for version 1. It breaks the beam between the four eights notes in the 3/4 which I would rather keep beamed together.

It’s hard to phrase, but I only want to beam across beats if both beats consist of a pair of eight notes.
In version 3, in the 3/4 bar, both beats 2 and 3 should be beam because they’re both pairs of eights notes. I don’t want bar 1 beamed in a group of three because beat 2 only has 1 eight note.

If my explanation is confusing, I can explicitly notate how I want the beams in another reply.

I’m afraid the current set of options don’t allow you to specify different results for 3/4 and 2/4 in this way. You could try setting the ‘Eighth notes (quavers) in quarter note (crotchet) denominator time signatures’ option to ‘Allow to cross beats’, which will provide the right behaviour for 3/4, then create your 2/4 time signature as [1+1]/4. But if that doesn’t work, then I’m afraid for the time being you’ll be doing some manual adjusting of beaming, and I recommend you set key commands for the Split Beam and Beam Together commands.

Already tried the [1+1]/4 trick and it didn’t work. Looks like it’ll be manual adjusting for now. Hopefully this area could be improved in a newer version. Thanks for your help!

Hi, I’m having trouble using the beaming options in 2/4. I’d like to break the beams of my eighth notes across beat boundaries and beam them together only when the group fills the entire bar (see one of the screenshots). However, this seems to have no effect on the score (see the second screenshot). Could anyone suggest a hint regarding what I’m doing wrong?


Keep scrolling. You’re in the section for time signatures that don’t have a half bar. 2/4 has a half bar.

That’s what I thought at the beginning! But the options for time signatures with a half-bar have no visible influence on my 2/4 flow. I consulted the definition again https://steinberg.help/dorico/v3/en/dorico/topics/glossary/half_bar_g.html and concluded that 2/4 does not have a half-bar according to Dorico (since it does not have four equal beats, which the definition requires).

Note also that Daniel had suggested using exactly these options in 2/4. If you take a look at his post above, the options he lists are from the part of Notation Options -> Beaming that’s about time signatures without a half bar. I assumed that if Daniel’s suggesting them for use in 2/4, then 2/4 did not have a half-bar…

I stand corrected - apologies.

From factory settings (hold Alt and then click where the Reset to Saved Defaults button normally is)

  1. Set the very first option in the dialogue to “Allow to cross beats”
  2. Set the second option to “Only when the group fills the entire bar”.
  3. Scroll down to Beams and Rests. Set Rests in beam groups to “Bream beams at rests”

You should get a result that looks like this:

If these settings are not affecting anything, select the problem passage (or even Select All) and go Edit > Beaming > Reset Beaming. I’d hazard a guess that you’ve imported MusicXML and haven’t previously turned off Dorico Preferences > MusicXML Import > Notes and Chords > Beam groups.

Thank you very much! This did the trick; and somehow ‘resetting to factory’ was the key, I was able to see no difference otherwise, and after this it worked. (This wasn’t a MusicXML import, I put it in by hand, but thanks for the guess :slight_smile:)

Incidentally, I have two buttons next to each other in Notation Options: ‘Save as Default’ and ‘Reset to Factory’. Alt is doing nothing to them (maybe since I haven’t saved any of my own configs as default?) It also seems to ‘Reset to Factory’ works only for the flow that’s selected in the menu to the right (in Notation Options). I like this and I hope it’s true :slight_smile: Please correct if I’m mistaken!

Now, getting back to my 6/4 flow, with the beaming in which I somehow cannot do anything via Notation Options. But I made a separate thread for that and if I don’t succeed I will go back there…

Thank you again!

Correct on both counts. If you’ve never set any defaults of your own, you’ll see ‘Save as Default’ and ‘Reset to Factory’. Once you’ve saved your own, you’ll see ‘Save as Default’ and ‘Reset to Saved Defaults’ unless you type Alt. If you hold down Alt you’ll see those icons change to ‘Remove Saved Defaults’ and ‘Reset to Factory’.

And yes, these options only apply to the flow(s) selected in the right side of the dialog.

Alright! Thank you very much again!