2 Midi keys not responding (keys are fine) while the rest are responding

I’m using Cubase 12 on Catalina.
my midi keyboard is a panorama P6 I’m using it on Omnisphere and I guess I should also state that I have a Stream Deck configured for Cubase via midi commands as well.
The issue is the two keys (A and A#) on my panorama P6 midi keyboard do not produce a sound when using Omnisphere, while the rest of the keys do.
They DO send midi signals and when outside of Cubase when I use omnisphere as a standalone they works just fine so we can rule out defective keys.

I’m guessing it’s something with the midi commands?
I am choosing my panorama P6 as the midi in on the instrument channel.
I would really appreciate it if someone could shed light on this issue for me thanks.


Please, make sure the MIDI Device (Panorama P6) MIDI Input is not in use as any Remote Device.

How do i do that?


Open Studio > Studio Setup, go thru all Remote Devices and make sure, the MIDI Input is set to Not Connected.

Hi Martin,
Won’t that interrupt my stream deck with communicating with Cubase?

This is my situation right now:


I wouldn’t use All MIDI Inputs at all. This means, all your hardware is blocked for MIDI CCs70-77.

Could you try, just for test, set this to Not Connected?

What about the Generic Remote and the Mackie Control devices?

These are the rest of them


Apart from the All MIDI Inputs, it looks OK.

What about the Chord Pads, please?

Hi, these are the chord pads.

Also I noticed that when I trsnspose on my midi keyboard the physical keys that didn’t work… now work.
And there NOTES that were trasposed still doesn’t work only now in a new phisical location on the keyboard


This is, because the specific MIDI Notes are blocked by any other (virtual) controller.

Please, set it to Not Connected. This might be it.

Will try and post results tonight thanks so much for helping

Another question meanwhile:
I won’t be losing any of my stream deck capabilities right?

Unfortunately, it did not work.


I don’t know, what is your Stream Deck controlling.

Oh no… There must be something, what is blocking these 2 MIDI Notes…

What happens, if you add MIDI Monitor Insert to the MIDI Track? Can you see the incoming data? When you press the key (send the MIDI Note) in question, can you see the meter of incoming MIDI Messages on the Transport Bar?

Hello, again Martin.
Yes, I do get midi data bars when pressing the said 2 keys.
I use my stream deck for a lot of functions in Cubase some are shortcuts, hotkeys, and track selections just to name a few.

Found the solution!
For some reason that I still haven’t figured out: it was the new Cubase 12’s midi remote option that silenced these 2 keys, canceled the profile, and…IT WORKS!

Now…the other issue…for some reason when I press e on my keyboard it both opens the edit on the selected track AND players a constant midi note.

1 Like