2 probs: Imported xml collisions & default page size - [partly solved]

Hi - first of all, thanks for your amazing work and dedication to this product!

  1. This file is an imported music xml exported from sibelius. There are many collisions, mostly to do with staff spacing. I’ve tried to address this in engrave mode, but it only adjusts the staves in the selected frame. If I go through adjusting every staff on every page I soon have problems with auto spacing. BTW, staff spacing and collisions is one of the reasons I am switching to Dorico, normally “well done” but with imported files things seem a bit wonky.

  2. When I export files from Sibelius it asks for compressed or uncompressed. Is there a preference?

  3. Dorico is not detecting my global location and setting the proper paper size. I constantly have to keep resetting instruments and parts to U.S. letter size. Anyone who has ever started to take a hammer to their printer when in a rush situation and it won’t print, only to eventually realize the software is asking for A4 will understand this frustration. :smiley:

I’m using Dorico 1.1.10 on a macbook pro, Sierra v 10.12.6

  1. Looks like it will be too tight no matter how much manual adjustment you do. You might wanna try a smaller staff size. Go to Layout options (cmd+shift+L) and you’ll find ‘Space Size’. Make sure the right layout is selected in the left hand panel.
    You should also check out the ‘Copy staff spacing’ function which you’ll find in the left hand panel in Engrave mode. This will let you copy manual adjustments from one page to multiple others.

  2. Here’s a short explanation of the compressed xml format. Shouldn’t make a difference.

  3. I think you may find some info on this here and here

Thanks Anders!

On 1 and 2 - perfect, easy enough, I’m a little embarrassed about that. Somehow, I assumed Dorico would auto-size staves upon import. Maybe it’s not something musicxml actually carries forward.

DEFAULT PAPER SIZE - The links did not address default sizes, but they were interesting and helpful. I read someplace that Dorico would detect my locale and set default paper size accordingly, which it is not. I have a bunch of scores imported from Sibelius. I’m having to go through every single part in every single score and reset paper size. God help the printer if I miss one of the parts and pull out the hammer again.

  • Obviously Dorico is failing to detect locale, or something has overridden the default paper size.

  • despite the defaults issue - is there a way to globally change paper size for all parts in an existing score? If not there should be.

Thanks to the Dorico devs who frequent this forum. It must be maddening to continually read “my problem is more important than everyone elses! this must be in the next update!”

I’ve never printed anything else but A4, so I don’t know how these stuff work in Dorico. But in Layout options, you can set page size, so this might be what you want. You can select several parts in the left hand panel. There’s also a ‘Save as default’ button there.

There are two different “paper sizes” to be aware of:

The one shown on the right-hand side in Print mode. This list of paper sizes is pulled from whatever default printer is installed on your machine. This size is ignore for the purposes of exporting graphics/PDFs. Instead, the one used is:

The layout size as set in Layout Options. If you open Layout Options you can shift select all layouts (or Ctrl/Cmd click selectively) on the left hand side of the dialog and then set the page size for all of them at once. It takes five seconds max including opening and closing the dialog.

OK - 1/2 good. I went into layout options, selected all the layouts, changed paper size to US Letter - brilliant.
BUT when I go to print mode and select any layout in the left pane the default paper size on the right pane is still A3.

I’m going to start a new thread focusing on this page size issue.