20ms offset when recording MIDI to audio

Hey guys, hoping someone can help me here. Here’s the setup;

iPad Air 2 64GB
iOS 9.3.1

So I load up Cubasis and Funkbox as an IAA. I route a MIDI track to Funkbox and monitor the output of the a
IAA audio channel. So far so good. Now I arm the IAA channel, and record the MIDI data and this is what happens;
image.jpg
The only thing that fixes this is setting the MIDI offset slider to 20ms but shouldn’t Cubasis be sample accurate? Even at 20ms it’s slightly off and I can actually see a bit of drift from beat to beat, although for the most part it’s usable.

Any ideas? I’ve tried;

Different latency settings
Different sample rates
Different IAA apps
An external audio interface
AudioBus
AUM
Airplane mode
System reboot

Same result in all instances. But weirdly, other users on the AudioBus forum aren’t having the same issue.

Would be grateful for any advice! I’ve got an iTrack Dock coming and have invested a fair amount in synths and effects to build a viable second/portable setup so I’d like to get all the kinks ironed out if possible!

Thanks :slight_smile:

Hi chimpspanner,

Depending on the 3rd party instrument options, it is possible to assign IAA instruments to an audio or MIDI track.

If you plan to record a Funkbox pattern to Cubasis, I suggest to assign the instrument to an audio track.
If you instead want to trigger the individual drum instruments of Funkbox from within Cubasis, assigning the instrument to a MIDI track might be the better choice.

Giving both options a short check with our latest Cubasis’ version and Funkbox on iOS 9.3.1 worked as expected.

Please have a look in the Accessories/Inter-App Audio chapter of Cubasis’ in-app help to learn how to assign IAA instruments to either an audio or MIDI track.

Hope that helps to solve the issue!

Best,
Lars

Hi Lars, and thank you for the reply.

Yeah if you look in the screenshots I’ve posted, that’s exactly what I’ve done. Funkbox is inserted as an IAA audio track, with a MIDI channel controlling it which I use to sequence the pattern before recording it permanently to audio. I find this is better than relying on pattern based synths to keep a steady sync with Cubasis, as virtually no app seems to be capable of that!

The problem is that when I do that, the resulting audio file is playing anywhere from 10-20ms too soon. I can actually work around this using the output latency control in settings. I thought 20ms was the perfect setting but this was lagging slightly behind the click so it appears to be more like 10, maybe 11 or 12.

I’d appreciate if you’d be able to test it on your end also;

Funkbox on an IAA channel
MIDI track routed to Funkbox
Sequence & quantize MIDI
Arm Funkbox for record and record the MIDI data as audio
Check the sample start position

I am pleased at least that there’s a control to adjust this, but it is weird that the instruments play back fine when triggered by MIDI, and yet are recorded slightly too early! Very weird.

Thanks in advance :slight_smile:

Hi chimpspanner,

Gave it a check but simplified the workflow:

  • Funkbox assigned to a MIDI track via IAA
  • Create audio track from recorded MIDI part via ‘Track Freeze’ button*

Please make sure that ‘Host Latency Tweak’ is set to ‘Cubasis’ in Funkbox.

* Please makes sure ‘Unfreeze Deletes Audio Track’ is unchecked in the setup/arranger section if you want to keep rendered audio files when ‘unfreezing’ frozen tracks.


Hope that helps.

Best,
Lars