3:2 bar divisions?

Why is Dorico introducing those 3:2 division when I record something on my piano?
That splits up the bar in a way which I do not understand. Thanks

Because Dorico has interpreted your playing as tuplets. If you don’t want that change the quantization options to ignore tuplets.

It makes sense. The only problem is: sometimes you are actually playing tuplets, thus quantization may harm the transcription in that case. Is there option in between?

You can select notes and Edit>Requantize…

I tried if and it sort of managed to correct the note lenghts, after some trimmering, but it did not remove the 3:2 on the piano roll.

The “3:2” markings appear in the ruler in the piano roll because you have tuplets in the music.

If you’re recording music in real time, you can specify that Dorico should not create tuplets in the first place by changing your quantization settings.

Ok, seems to work now, thanks.