3.5.1 Paragraph Styles - Save as Default broken?

The “Save as Default” star in Paragraph Styles doesn’t seem to be working in 3.5.1. Previously I could hit the Save as Default star and then that style would be available to select as a key command for System Text. Now many of the styles appear, but Save as Default won’t activate any additional styles to be selected. For example, I can select my Paragraph Style “System Text,” hit the Save as Default star, but when I go into Key Commands it isn’t available to select anymore. Is this a bug? Is there another way to add Paragraph Styles now so they can be assigned a Key Command and I just missed it?

This? Not an answer though. https://www.steinberg.net/forums/viewtopic.php?f=246&t=195385

Hmm, definitely could be related if it won’t actually change from Revert to Factory. I only noticed because I reformatted my hard drive a couple of days ago but forgot to back up my keycommands file, d’oh! Since I was moving everything to my new desk I figured I might as well start with a clean install since it had been a few years since I wiped the drive. When I went to reassign that key command, I found I can’t actually do it now within 3.5.1, unless there’s another way to accomplish it. I can probably pull the keycommands file off my laptop and see if that works.

I’ve just tested this out and everything still appears to be hooked up correctly for me. You should be able to verify that things are working if you look for the name of the paragraph style you’re saving as default in the userlibrary.xml file you’ll find inside your user data folder: it should appear in there. I also find that those paragraph styles show up in the Key Commands page of Preferences, and the shortcut I set up works as expected in Write mode…

So I’ll need some more details to pin down what might be wrong here.

Presumably this should be in AppData/Roaming/Steinberg/Dorico 3.5 right? I don’t seem to have that file in there. This is on a hard drive that was just reformatted, a clean OS install, and 3.5.1 newly installed. Does that file install with the program, or is only created after a user makes modifications to something?

It’s only created after a user makes modifications. It’s possible that the problem is related to the specific style you’re trying to save as default, I guess. Can you share the project containing the style you want to save as default with me? You can email it to me at d dot spreadbury at steinberg dot de. Be sure to let me know which style it is you’re trying to save as default.

Just emailed, thanks for investigating!

Thanks for sending the file, Todd. I can now reproduce the problem: if you go into the Paragraph Styles dialog and click the “save as default” button for a style you’ve not edited during that session of the dialog, it fails, due to a small logical error in the dialog code, which we’ll fix. In the meantime, you should find that if you make some changes to the style in the dialog session, you can successfully save it as a default. Sorry for the inconvenience caused.

You’re right, if I change the point size for example, then hit Save as Default, it now appears in the Key Commands list. Unfortunately, even when I assign Shift-Alt-X to that new style, when I invoke the command in a file, the “Default Text” style is still the one applied, not the one I selected in Key Commands. Even if I pick one of the styles that was already appearing, I can’t seem to update Shift-Alt-X to be any style other than Default Text, regardless of what I select in Key Commands.

It seems like assigning the Key Command doesn’t really “take” as I get this message:

I’m assuming that “System Text” should be in that box where the “?” is. Does the “?” mean that Dorico isn’t correctly processing the Key Command assignment?

When I went to Key Commands / Print Summary I noticed this:

Dorico made the new key command assignment but seemingly didn’t remove the old one. (Maybe?) So I decided to search my keycommands.json to see how many times it appears. It only shows up once in my file (see “1 match” below), with the command I assigned:

So where is Dorico finding the Shift+Alt+X command for this Default Text paragraph style? It’s not in the keycommands.json file. Is it hardwired in somehow in 3.5.1? Can I remove that command from another file somewhere?

It’s only once in the main keycommands.json above, but appears like this in the user keycommands file:

I’m still not sure where the defaulttext style for Shift+Alt+X is coming from though.

The default shortcut for creating system-attached text using the ‘Default text’ paragraph style is Shift+Alt+X, so it’s coming from the defaults file. If you add the following

			{
				"context" : "kWriteMode",
				"shortcuts" : [
					
					{
						"NoteInput.CreateSystemText?ParagraphStyleID=paragraph.defaulttext" : [ "DELETE:Shift+Alt+X" ]
					}
				]
			},

to your key commands file, that will remove the default shortcut and should allow your new one to work. Because you should have other key commands in the kWriteMode context already, you should find that you can add just those middle three lines to your existing kWriteMode section. Just be careful with commas after the closing square bracket: if it’s not the last shortcut in the section, it will need one, but if it is the last one, it must not have one.

Works great now, thanks Daniel!

This is happening to me now (3.5.12). I set up a paragraph style “Lyric translit”, clicked on the star/set as default button and applied/saved the style. It shows up in the current project, but does not show in new documents nor in key commands (under create text/system text).

What do you recommend I do to troubleshoot this? )Or, what am I missing?)

Thanks very much.

Deka ti e Tinke-support.dorico (447.3 KB)

Sorry for the inconvenience, but you’ll need to make a small adjustment to the style in order to save it. Open your project, go to the Engrave > Paragraph Styles dialog, select your Lyric translit style, and make a tiny change to its settings: for example, you might try changing Word spacing to 0.5pt. Then click the star button to save it as a default for future projects, and you should find that it does indeed appear in new projects when you create them.

Thanks for the reply, Daniel. So, I had tried this before, but tried again. No joy. It doesn’t show up in a new project. I tried quitting Dorico, and re-opening. No again. Tried restarting the computer, etc. no again. I must be doing something wrong. In two new documents, I tried it in a text box in Engrave mode and also as System text in Write mode. What am I missing?

Thanks,
David

I’m not sure. But I can fix this for you. Go to your user-level application data folder for Dorico:

Windows: %APPDATA%\Steinberg\Dorico 3.5
macOS: /Users/your-username/Library/Application Support/Steinberg/Dorico 3.5

and find the file userlibrary.xml contained within. Zip that up and attach it here, and I will graft in your paragraph style and send it back to you.

Daniel, you and your support team are too great. I decided to start over, and this time I changed the order in which I clicked and favorited and applied changes, and this time things worked and I can use the styles in new docs. I couldn’t tell you why specifically it worked this time and not last, but it did, so no need to trouble you.

Thanks very much.

Sorry for the inconvenience caused! This will definitely work more reliably in the next version of Dorico.

1 Like