3.5 bugs?

I’m wondering if I should have stuck to my usual rule and waited until the second or third iteration of a new version…

1/ Imported Flows do not play the sounds I’ve set for them in 3.1, it appears to revert to the default voice for the part name. For example, when I write a vocal part I often change it to a cello sound in the Halion player - I can’t work with that ah sound, too slow on the note hits. Imported a flow with a vocal line and it’s playing the voice Ah sound…so I’m guessing that the Flow does not contain information about players instrument assignments - other than the default by name? And that swapping the played sound is a Project setting and not a flow setting? If so then that’s my bad for not knowing.

2/ Several times I get no audio after starting Dorico 3.5. had to restart.

3/ the mixer doesn’t appear to be working - no longer allows me to solo or even view the outputs from each instrument. The meters are not even moving - apart from the reverb and main output.

3/ Missing fonts. No, they’re not missing, they were used in 3.1 and this is the same computer. And if I bring up a text box I can select the missing font.

Worried about opening a large project created in 3.1 and thinking I’ll create a separate folder for 3.1 projects and keep 3.1 on my system until things settle down. Staring new projects maybe ok but I get nervous when opening a project with months of work that starts to misbehave like this…

Comments and thoughts welcome please.
Screenshot 2020-06-05 19.41.07.png

1: importing flows doesn’t import players, as I understand. Either you can match existing players, or new players according to the instrument type are created.

Whether you can bring up the font is irrelevant - can you bring up the specific style of that font? I certainly can’t - Font Book tells me that I have no such style of Avenir installed.

Are you importing flows into a brand new 3.5 project?
Did you try simply opening and saving (at least) the first flow as a 3.5 file and then importing subsequent flows into that?

Thanks for the responses.

Re the players not carried into Flows, I guess that’s the way it is. Not a big issue as it’s generally just the voice that I swap out.

Re the fonts - I still get the alert missing message on opening this particular project, as per my screenshot - but all the font styles are available, and the default I use is Avenir, titles etc all present and correct. I just tried adding some text and was able to select and view every style of Avenir. So definitely something not quite right with that alert.

Re the mixer - a mystery - today it’s working fine.

Thanks again for all your input.

Including “Regular”?

I’ve been using Avenir regularly for a number of projects over the past 7 weeks (starting in 3.1 and then using 3.5 from as soon as it came out) and I always get that missing font dialogue, but it’s harmless as the file opens up normally once I’ve pressed ‘OK’.

I remember some discussion about how the missing font dialogue worked back when it was a new feature in version 3.0 and, whilst I can’t remember the details, I think it has something to do with the lack of a ‘Regular’ font-style in certain fonts and that it is ultimately harmless when it appears in these circumstances.

3/ Missing fonts. No, they’re not missing, they were used in 3.1 and this is the same computer. And if I bring up a text box I can select the missing font.

I have this behaviour too in 3.5. The alert is popping up, that even system fonts on my Mac are missing.
But if I don’t doo anything then and close the warning window – miracle, miracle – the fonts are showing up correct.

To summarise the reason the Missing Fonts Dialog appears:
Some Dorico Font Styles and Paragraph Styles inherit properties from parent fonts.
For instance, the Composer Paragraph Style (by default) is a child of the Default Text Paragraph Style: it will use whatever font you’ve set for Default Text, but it will use the Regular style and show it at 10pt.

If you set your Default Text Paragraph Style to use a font for which no “Regular” style exists, you need to either:

  • go through and tell all of these child Font/Paragraph Styles to use a variant of the font that actually exists, or


  • ascertain that these Font/Paragraph Styles aren’t in use in your project and thus won’t cause problems (e.g. if you don’t have a harp in your project then the Harp Pedal Settings Paragraph Style is unlikely to cause you problems), or


  • accept that, while everything may display fine on screen (because Qt can synthesise or substitute font styles that don’t actually exist), there might be problems when you print or export graphics.

If there really are situations where the Missing Fonts Dialog is appearing and the listed Missing Style appears in Font Book (or in Windows Control Panel > Fonts > View Installed Fonts), I’m sure it’s worth reporting it here.

Thank you for that, Leo, really useful.

The point I’d like to make in relation to this and the OP is that the behaviour hasn’t changed for me in this regard between 3.1 and 3.5.