3.5 Down arpeggio with arrow has a messed up arrow, in any font other than Bravura

I have some “down” arpeggios with arrows which displayed perfectly in Dorico 3.1. In Dorico 3.5 the down arrow seems to be flipped the wrong way. Disclaimer! I use a custom SMUFL font, and obviously this is the problem. In Bravura, arpeggios with down or up arrows look fine. I wouldn’t post at all, except that I checked and this down-arpeggio problem appears in Petaluma, too (and November 2.0), so it seems there’s something bigger going on.

I can workaround this, of course, but obviously I’d prefer not to…

Otherwise, huge congratulations on Dorico 3.5, which continues pushing all notational boundaries and making the program more functional with each update!

ArpeggioArrows.dorico.zip (597 KB)

Yes, as part of the revamp of how lines work in Dorico 3.5, the direction of the down arpeggio glyph has had to be reversed. It looks like we may have missed doing this in Petaluma, for which apologies; we’ll sort that out as soon as possible.


I could fix this with my BopMusic font, thanks a lot for pointing that. :bulb:

Dorico 3.5 macOS Catalina



I have the same problem with arpeggio, but my version of Dorico is 3.1.1.
Currently I am doing a revision of my score, that I did in Dorico 2 and all the down arpeggios are wird.
How can I fix it?

Have you installed the trial version of Dorico 3.5 and hence ended up with a later version of the Bravura font than is intended for use with Dorico 3.1? I believe the latest version of Bravura at the time of Dorico 3.1’s release was version 1.271, which you can download here.

Yes, indeed I installed Dorico 3.5 by mistake (I thought it was a free update) and immediately uninstalled. Now I downloaded version 1.271 of Bravura and it seems everything is ok. Thank you!

Is there any way to fix this? I am running into this right now.

Also, I am using Bravura… Dorico 3.5 latest update.

Can you check what version of Bravura you have installed? It should be version 1.39.

I looked in the .json file and it shows I have 1.39.

Try installing the attached version of Bravura, version 1.391. Provided you’re running Dorico 3.5 or later this version should certainly produce the correct arrowheads for arpeggio signs, so long as you’re using Bravura itself in your project of course.
Bravura.otf.zip (380 KB)

Thanks Daniel, that OTF fixed it. The only thing I can think of is that I installed a new version of MuseScore to act as an XML conversion intermediary step - that might have downgraded Bravura.

Hi! I am having the same problem and decided to follow Daniel’s advice. Before I do though, I just want to double-check: AFAIK SMuFL-fonts only work in conjunction with a corresponding metadata-json-file. Do I need to update that file as well or should the old one that I already have work fine?

You’ll be OK with the current version of the metadata file.

1 Like

I installed that Bravura font, rebooted, fired up Dorico (windows 10), and checked to make sure the font was installed correctly. I’m getting this:Slice 2
Note that I used the “M” command to move some of the lowest notes, but moving them back to the upper stave gives the same up-arrow.

Can you verify that you really do have version 1.39 of Bravura installed somehow? (I can’t quite remember how you do that on Windows, but I believe there’s some way of seeing the version number in the Control Panel Fonts applet.)

In Windows, press the Windows key, and type Fonts, then Enter. You’ll see the fonts manager, where you can see what version you have installed of each font.

Hi Daniel,

Here’s what Settings > Fonts shows for Bravura:

But I just noticed there are two (“Bravura Text” in this case) . Here’s the other one:

Here’s a one-measure file with the down arrow, in case it helps. It has several of them in that measure.
ArpeggioDown.dorico (471.9 KB)