3.5 Licensing / E-licensor issues sorted?

Have the long standing issues regarding the e-licensor error that continue to plague me despite buying an additional new USB licensor stick, been resolved with this upgrade?

I have only Dorico on the new stick, leaving all my other Steinberg apps on the old.

I still get the dreaded “Failed to send GetInfo command” and no licence found, etc . Just been working on a project all day, closed the app for a tea break, came back to print and cannot get Dorico open. Before I shell out a modest sum for an upgrade it’d be great to hear that this problem has been sorted. Buying a newer Licence stick was supposed to be a solution…

Anyone know?

Ah I see I accidentally logged in from an unused older profile - hadn’t logged in for a while on this mac so just selected the first option that it offered - anyway I hope there’s an answer to this question from Steinberg or (many) other users who had this problem.

A little more patience please. We have a release candidate currently in beta that addresses these issues. If our beta testers don’t find anything any more, it shall soon go public.

Thanks Ulf - though patience is a little thin when this has been an issue for so very long. Had to re-start my computer twice to get Dorico running again today. Extremely frustrating.

Great to have new features but not at the expense of reliability…

Sure, fully understood. But I dare say, there’s light at the end of the tunnel, so please hold on.

Thanks Ulf - I look forward to it. Today after working all day with Dorico and a despite a restart I am stuck unable to use the program…

Is the beta version you speak of Dorico or the e-licensor app? Having spent money on the newer stubby USB key on Daniel’s advice, I’m reluctant to spend more money on the upgrade until I know it’s solved the problem. Right now in the middle of a large project I really don’t need this aggravation!


It’s the e-licenser app I’m talking about.

great. let’s hope!