32 Bit Float is NOT working in Export Audio Mixdown

32 Bit Float seems to work just fine in the “render in place” feature. But when rendering files via “Export Audio Mixdown”, 32 bit float is not retaining ANY data above 0db like it should be.

In the video I’ve rendered in place a clipping kick via 24 and it seems to work fine. Then I render in place the kick at 32 bit float and it works fine… Then I render at 32 bit float via Export Audio Mixdown and it the file is clipped. It should be the same file as the render in place file…

So wtf Steinberg!? Is 32 bit float really just 24 bit now in the export module? This hasn’t always been the case. I’m not sure when this happened, but 32 bit float used to actually work in the past. I’ve also tested this out with the batch export and it’s broken with that too.

This has caused a TON of pain for me, because now I’m finding a lot of my kick drums from previous projects are clipped when they shouldn’t have been. At first, I thought I perhaps had just selected 32 bit instead of 32 bit float by accident… but then I did a little more troubleshooting today.

https://youtu.be/N7_6nNoPXv4

Hi,

I tried to reproduce it here on my side and it works as expected. Therefore I would like to ask you for some more details, please.

  1. At the very beginning of the video (0:03) you open the Channel Settings window. What does it mean that the PRE section is blue? I have never reach this. Do you use any PRE setup?

  2. The first 3 Renders… I don’t get the settings of them. Could you make another video, where we could see the Render in Place window settings, please? Do you export the Complete Signal Path + Master FX? How is the other setup? Why there are 3 Render in Place exports (I would expect 2 of them: 24bit and 32bit float)?

  3. What is your Project Setup: Record File Format? Is it 24- or 32bit float?

  4. When you import the files after the Render in Place/Export, how is the Import Options setup? Do you Convert to the project? Could you show this dialog on the video, please? Or do you have no dialog and stable settings in the Preferences > Editing > Audio > On Import Audio File…? What is the settings then?

Oh snap. I checked my project settings and it was set to 32 bit, not 32 bit float. I think I see what happened. I have an “empty” template that I use on almost all my projects… and it’s essentially empty but with some minor changes. Anyway, I’ve had it set to 32bit float but after one of the updates I think I had to remake the template for some reason. I think it set the bit depth to 32bit instead of 32bit float… (this must be when they instroduced 32 bit). And I must have saved the new template without realizing the projects bit depth was not the same.

Weird thing is that if I switch the project settings to 32bit float and then switch it back to 24 bit, it will also work… even though the project settings are at 24 bit at the time of export. It’s also very counter-intuitive that this would affect the ‘export audio mixdown’ but wouldn’t affect the ‘render in place’. So that threw me off.

But it looks like I got it all figured out now and working; thanks!