32 core Ryzen Nuendo 10 audio dropouts.

I was recording additional tracks to an already 90 track project. I have the disk meter running which shows under 5% disk and no CPU or memory meter. During recording of these tracks I am experiencing multiple audio dropouts. My client was not happy.

I am using direct monitoring using the latest RME HDSPe madiFX driver on Windows 10 and have 128gb of DDR4 3600 memory. I have my buffers set to 2048. I am only using 10% of the PC’s resources while running tons of pluigns from Steinberg, Wave, Duendo, izotope, Slate, etc.

Only sometimes I could record multiple tracks over the entire song but it was hit or miss.

I have tried limiting my CPU cores to 12 in Windows and in the bios to no avail. The dropouts continue to happen even on a new project recording only 1 track while playing back 1 track with no plugins. I formatted the drive with a fresh window 10 install and only Nuendo 10. Tested recording again only to get audio dropouts

Because of the audio I had to export the Nuendo 10 project as omf and import into Protools HD on the Mac where there at no audio dropouts.

Anyone else experiencing dropouts using multi core CPUs on Windows 10 and Nuendo 10?

That’s a major bummer.

The one thing I read about recently was that some people got problems with the latest version of WIndows, I think it’s 1903 (I’ve deferred updates for now so I can’t recall the exact number). They used a DPC latency monitor to check high latency and supposedly a lot of people got high latencies reported. These aren’t audio buffer latencies but other system latencies and when they’re spiking high enough you can get audio stream problems.

Another potential guy to look at is the nVidia card. Same deal with ‘interference’.

I mean, let’s hope this is not a CPU issue, and it doesn’t seem to be because why would you get so far before getting problems and then stripping down to a new barebones project with 1 track recording 1 track playback you have problems? Seems like the issue lies outside of the CPU - unless it’s physically broken somehow.

Also, what settings have you chosen in Nuendo specifically for audio, other than buffer size? And what else have you tried?

After a reinstall of Windows 10 x64 and Nuendo 10, I started with no settings. It’s plain vanilla with nothing else installed including no plugins. I chose my RME HDSPe madiFX driver and set up my basic IO and using direct monitoring with 2048 buffers. Recording 1 track causes intermittent audio drop outs. The CPU, memory, and disk meter shows no activity including while the dropouts happen.

What OS version and build?

The OS and build that has audio dropouts.

Windows 10 Pro X64. - no MS patches
Nuendo 10
ASRock Fatal1ty X399
AMD RYZEN Threadripper 2990WX 32 Core
128GB DDR4 3600 Memory. GSkill Trident Z
RME HDSPe Madi-FX - latest drivers
RME HDSPe AES x 2 - latest driver
EVGA Supernova 1200 Platinum PSU
Custom loop water cooler

If you press the windows key and then type “about” you should see “about your PC”. If you choose that you should then see at the bottom exactly what you’re on. For me it’s:

Editions: Windows 10 Pro
Version: 1809 <—
Installed on: 1/20/19
OS build: 17763.503 <—

If you say you have no patches I suppose you’re on the “first” version of whatever your installer provided. All I was getting at was trying to see if you were on version 1903, which was the one with reported problems.

I checked. For me it’s
Windows 10 Pro
version 1809
OS Build 17763.503

Not sure what version I had before I formatted and fresh install.

1809 has been good for me, 1903 is the one with more reported issues. Have you checked your DPC latency? My guess is that you have a driver that is causing the problems.

I’ve been wondering if Nuendo has declining audio record performance since seeing some of these threads. So I decided to hammer it a bit and see for myself. System specs in my Sig.

Playback and Record on same 4TB Seagate spinning platter
128 Sample Buffer
Multiprocessor ON
Asio-Guard On/Normal
Thru-Software Monitoring (Direct Monitor-OFF)
All other hardware settings at Default
Project is 127 tracks (many stereo and a few VSTi) with about 200 plugins
I added 64 Mono Audio tracks being fed by 64 Mono inputs from RME MADI card

While playing back the full session, I recorded all 64 tracks simultaneously for 10 minutes without issue. At least on Windows 7, there appears to be no inherent fault in N10 audio recording.

My guess (as suggested above) would be a driver that has not been Win 10 optimized, while throwing in forced MS updates along the way as an additional joy to troubleshoot. The offending driver may well not have anything to do with audio, directly.

Hope you resolve it soon!

I am using Samsung 970 m.2 MVME 500GB OS drives RAID1. I tried RAID1 and no RAID OS builds but had the same audio dropout issue using both. I record to both HDD and SSD drives. The disk meter within Nuendo does not show any activity.

I just read that the latest OS version apparently assigns threads better than before, so perhaps try that if you haven’t already.

Not to beat a dead horse on this, but have tested your DPC latency yet? With your specs, you should be have tons of headroom on your machine, and it is probably a misbehaving driver causing DPC spikes.

My posted test above was just to confirm that N10 has no inherent audio recording flaws as compared to previous versions. At least on a known system, such as Win 7. Win 10 and OSX both receive a steady stream of updates. Sometimes that breaks things and then either the OS maker or the software developer has to fix it. “It just works” left the building long ago.

Or, it could just be a bad combo of hardware and drivers. If you’re having dropouts when recording just a single track, something is very off. Your 32 core CPU is rare in a DAW and that does make you a potential guinea pig for changes by Microsoft. I’ve been there and done that myself.

Test your DPC latency. For sure your best move at this point.

On my current build, I remove the RME Madi card and AES card and installed my Pro Tools HDX 3 cards. Tested Pro Tools HD 12.8 and tested.

I loaded a 260 track movie and recorded an additional blank tracks. There were absolutely no audio dropout during the entire movie.

I removed the HDX cars and installed the RME cards. I ran Windows update and updated the RTX 2080 driver. I launched Nuendo 10 and opened the know audio dropout song file. I played the song but this time had no audio dropouts. I played the same song but added 100 additional blank tracks, hit record and no audio dropouts for 10 minutes of playback and record!!!

I guess Windows Update resolved the issue. I will continue to test before I feel comfortable using Nuendo 10 with paying customers.

Yes, have posted about this a number of times before: slightly different context - screen updates freeze regularly, every few minutes or so, the freezes happen twice, then wait again for another few minutes. In general, audio continue to play but am locked out of any editing, mouse or control surface functions. This happens on such a regular timing cycle that it feels like some kind of ‘polling’ by Nuendo.

Finally, I should add that the computer, drivers, OS etc are all optimised and working well (& without going into endless Q&A about versions, tech details etc). The main point is: this behaviour does not occur with any other program except for Nuendo: that includes Pro Tools Ultimate 2019.5, Ableton Live Suite 10.1, Studio One 4.5 & far more demanding NLEs for that matter, eg: DaVinci Resolve Studio.

EDIT & UPDATE: 27 Oct 2019
Went back to this and dug deep after very annoying performance on a film project:

  • went through all the usual: clean install, fresh prefs, minus 3rd party plugs, optimised Win settings, etc etc. None of this made any difference, behaviour exactly as per above post.

Overall, I have now found that this is 100% related to GPU & drivers. Without getting into ancient raves about ‘audio production & GPUs’ - it is 2019, and many of us need and use high end GPU tech for other important studio rendering requirements like for film prodcution, music-to-picture etc. AND, this is Nuendo (10.2) which is meant to be designed for pro POST.

Now, there are many threads about exactly this issue, on the Steinberg fora for Nuendo & Cubase as well as various external production sites. The most common ‘fix’ recommendation that comes up is to ‘disable G-Sync’ via the Nvidia Control Panel. However, the thing is that this option doesn’t necessarily appear, depending on what display(s) are being used. G-Sync (Freesync) monitors are for gaming. In my case, the Displays are selected for 10bit colour accuracy, user calibration & film production - so, no ‘G-Sync’ option (or Freesync in the Displays themselves) though this can still be manually disabled via 3rd party tool, Nvidia inspector

I disabled G-Sync this way (but likely unnecessary because these particular Displays do not use it).

Final fix:
Override the default GPU settings & make a custom profile for Nuendo /Cubase in the Nvida Control Panel: 1) use ‘performance mode’ and 2) turn off V-Sync (this produces lag). The problem has finally gone. Other Nuendo settings FYI: no auto save, no auto hit-point detection, Steinberg power scheme, Hi DPI, 64bit processing. All good, at last.

Hopefully this might help someone else.