[3rd Party Issue] Final Touch disconnecting in Cubasis

I’ve been using the excellent Final Touch(Positive Grid) mastering app as an Inter-App audio plugin in Cubasis for about 6 months without any issue.
Now with the latest versions (Cubasis 2.6 and Final Touch Final Touch seems to disconnect from Cubasis during use.
It works fine for 10 seconds or so, then stops processing data. Cubasis and Final Touch are both still running so it seems the audio stream has broken or something…?

I’ve tried rebooting the iPad and I’ve tried this with different projects with the same result
iPad 5thGen(2017) 32GB

Is anyone successfully using this workflow?

Hi 642carl,

Thanks for your message, which I’ve shared with Positive Grid.

To support them and us, please provide us with a detailed bug report to easily reproduce the problem. Furthermore please let us know what iOS version you have in use.


Hi 642carl,

Positive Grid’s support team provided me with the following response for you:

To make sure Final Touch works with Cubasis, we will need to ask the user to launch Final Touch before Cubasis, and then launch Cubasis -> load Final Touch in it. The user must update to the latest version of Final Touch, which would be more stable. This should resolve the issue.

Please let me know, if this helps to solve the issue.


  1. Summary/Title
    Final Touch stops working after a while when used as an Inter-App Insert

  2. Description
    You can reproduce this with the demo song (Smear)
    a) launch Final Touch, select a preset (i like Country Basic and Country Rock for most songs)
    b) launch Cubasis, load the demo song
    c) select Final Touch as an Insert on the Master (stereo 1/2) output (Final Touch opens)
    d) switch back to Cubasis and start playback of the song
    e) wait… and Final Touch will stop processing audio after anywhere between 10 and 120 seconds typically

  3. Expected Results
    This worked fine and consistently on older versions of Cubasis and Final Touch

  4. Actual Results
    While Final Touch is still “working” you can open it from within Cubasis Insert Slot (touch FT icon in slot to open)
    Once it stops working, the icon no longer opens FT (although you can context switch to it with the iPad home button)

  5. Environment
    I’ve tested this on an iPad 2017 and an iPad Pro (9.7) with the same results, both with new and the demo project.
    ** Final Touch
    ** Cubasis 2.6

** I’ve used this workflow for about a year on my old ipad 4 (32-bit os)
** Final Touch
** Cubasis 2.3.1

I discovered that if you switch context to FinalTouch (via iPad home button) while Cubasis is playing the song, it seems to continue working indefinitely (I’ve let it loop for 5 minutes) When you switch context back to Cubasis, it dies pretty quick…

I was aware of this, and I’m using the latest version of both Cubasis and Final Touch. I just tested this on an iPad Pro 10.5 with the exact same results. Still works fine on my old 32-bit iPad 4 with older versions of both apps.

Can someone please confirm this bug?
It’s very easy to reporoduce…

Hi 642carl,

Please get in touch with Positive Grid about the issue.
We’re at hand to support them if required.


Thanks Lars, apparently this is a known issue…

Thanks for sharing the info, 642carl!