4.3 super buggy shortcuts

I tried assigning all kinds of different key combinations to open the bottom Panel and the Editor. It works completely erratically, but most of the time it won’t.

Also, shouldn’t this be a Toggle?

Doesn’t Cmd/Ctrl-8 work for this?

Ctrl+8 opens the bottom panel, irrespective of which window you want to see. I saw that now there are new commands to open specifically Keyboard, Properties, Key Editor, etc. That what this bug report is about.

What shortcut(s) have you assigned to which command(s) that you are finding not work? Can you detect any pattern when they appear not to work?


As you can see I have tried a multiple of combinations, from simple one key to using modifiers

And do they ever work, or do they appear only to work sporadically? Can you detect any pattern as to when they work and when they don’t, for example when a particular panel is already shown in the lower zone, or when you’re in a particular window mode, etc.?

Nope, tried every conceivably combination of open panels, closed panels, opening the panel with the mouse, with Ctrl+8, etc. Can’t seem to find any pattern. But I’ll say it works 1 out of 50.

Yes, OK, I think I can see why this might be a bit unreliable. The command is probably being disabled when it shouldn’t be, though I’m not entirely sure why. We’ll look into this.

2 Likes

Yes, I experienced the same issue after I updated to 4.3 (coming from 4.2), none of the lower zone panel key commands I set were working. Until I closed the project and opened it again, then they worked fine.

This behaviour is reproducible here, I just updated my second computer to 4.3 (coming from 4.0) and the same thing happened:

  • First launch after update
  • New project
  • Set new lower zone panel shortcuts for Key Editor and Properties - they don’t work
  • Close project
  • Start a new project again
  • Now the shortcuts work

@Bollen your key commands should be working for you now that you probably closed Dorico. Can you confirm?

I second that. It would be great if the panels key commands worked as toggles and closed the lower zone entirely. Currently, if I’m working on the Key Editor (W here) I have to press ctrl+8 to close the lower zone, when it feels more natural to just press W again. Shift+W switches to Properties, intuitively I press shift+W to close the lower zone, but nothing happens. Anyway, just a quick request, don’t want to derail Bollen’s thread.

2 Likes

Sorry, I haven’t had an opportunity to sit down with Dorico again. But I’ll get back to you when I can. I believe I had to restart the PC several times during my session anyway, since I had some iLok updates and other things, and the problem persisted.

I’ve setup key commands for Preferences and Key editor and it works fine for me except in play mode where my Preferences shortcut will open the lower panel but will not choose between the mixer and the preferences. Maybe because it’s the only mode where they appear in reverse order?