4.3 update broke playing through headphones/internal speakers [Windows only]

I just tried to look into it, as I have the same problem (Windows 10, 64GB RAM, CPU
AMD Ryzen Threadripper 1920X 12-Core Processor 12 Cores), when I am “just” in the Generic Low Latency ASIO Driver (which I use for Sibelius as well), I can’t select anything in the stereo output as nothing is in there.
When I choose something different (which I’d rather not do, as I need the rest of the computer audio available when using Dorico) I can at least select something.

The audio samplerate of the PC is set to 48.000, so no issue there (neither was there one before the update ^^)… currently everything is very “left leaning” coming from my speakers.

Thanks in advance for all the help.

Hello!
Regarding the same matter.
After installing Dorico 4.3 I have rattling, distorted sound. I managed to fix it by clicking the “Allow ASIO host application…” button in the Device Setup, but then I cannot watch YouTube-videos at the same time. This time I’m not able to fix the issue with the “Trouble-shooting Playback Issues in Dorico” -video, that previously worked out fine.

In the Generic Low Latency ASIO Driver popup, as well as in the Device Setup popup, 48000 is the only available value in my case.

The ASIO box was unchecked under “Card Options”, as announced in the 4.3 version history, but I was unable to watch one of Anthony’s videos on YouTube at the same time.

FWIW for me using the PreSonus Studio24c with Dorico 4.3 there is no issue with headphones, and all the bit rates are available. [Sometimes I wonder if it is just noise to make posts saying it all works, but I suppose it goes to show it is not a universal problem, which may or ma not be helpful.]

I guess you’re not using the Generic Low Latency ASIO Driver then. Issues seem to be all related to that one.

3 Likes

Hi all,

first of all, I can confirm the issue, happens also on my machine here.
Second, the workaround is to switch on the exclusive access option at the top of the control panel window. Then the headphones/speaker outputs will become stereo again.
Of course, the downturn then is that you can’t have other apps (e.g. YouTube) play out at the same time. A solution to that we don’t have (yet) and you may need to wait a bit. As I’ve just heard, our driver guy is unplanned absent due to illness.
I will come back with news as soon as I have them.

1 Like

Hello again,
lucky you, I’ve figured the solution myself:
The problem is not the driver but the device settings on Windows.
In the taskbar, right click on the little speaker icon and choose Sound Settings. Like shown in my screenshot, go to the properties of your internal speakers or headphones output and then click on the Advanced text (see also screenhot), a new little window will open. In that new window go to the Advanced tab and voila, at the bottom there uncheck the Enable audio enhancement option (see also screenshot on the right).


That’s it, press Apply and the speakers/headphones will be stereo again, even when in non-exclusive mode of the Generic Low Latency Driver.

5 Likes

I suspect this is due tot he fact that you’re using a dedicated interface, and not the generic driver which feeds a computer’s headphone port directly. None of the other users who seem to be having issues have made any mention of having audio interfaces.

For those who have an Enhancements tab, select ‘Disable all sound effects’.

It might be worth someone changing the subject of this thread as it is of course not only headphones that are affected.

2 Likes

@Ulf
When I right-click the speaker icon, the screen I see looks nothing like yours; nor does the Advanced Options panel.

There is an “Advanced sound options” menu at the bottom of your screen. What does it show if you click on the “App volume and device preferences”?

What release of Windows is this?

Click Device properties and then Additional device properties (or just begin in Control Panel).

Neither of these terms exist and the Sound option via Control Panel has no Enhancements tab.

Device properties appears in your screen shot.

Do you mean Device Preferences? That doesn’t lead to anything like the panel in Ulf’s screenshot.

Hi @Derrek , Device Properties does appear on your first screenshot. It is above Master Volume and pretty small and faint to see, but it is there. So please click there.

Thank you, Ulf and tristis. I had overlooked it; I had no idea an active link would be dimmed (my eyesight missed it entirely), but that was the key.

In my case there is no “Advanced” link in the Enhance audio section:


Instead it just has a dropdown that was set to Device’s standard effects (or whatever the English equivalent text is) and simply changing it to Off brings back 2 channels output. This applies to both Headphones and Speakers settings.

I did notice that after selecting Speakers in the Device Control Panel when Headphones was selected before, even when my headphones are now unplugged and Speakers is the only option, the Stereo Output dropdown in the Device Setup popup still shows Headphones as only selectable option. But that’s probably a separate issue, and the sound is effectively coming from internal speakers so not a big deal.

1 Like

That one worked!!!
Thanks a lot!

But I hope an update will negate this step soon :slight_smile: