4GB File Limit on Orchestral Templates????

I was doing so well getting ONE orchestral template filled up with an articulation per track (disabled of course), until I apparently hit the 4GB file size. Went to open it now and got the dread Cubase version 1x error message. See screenshot.

Seriously Steinberg, if there is a file size limit to your CPR files, WRITE IT IN THE MANUAL, or better yet, don’t allow us to save! That way we will still have the working file open. Ugh…
Template (CPR) files Get Corrupted at 4GB.jpg

Hi,

I’m not aware of any kind of limit. What is so big in your project?

How is your HDD formate? Do you use HDD or SSD?

It’s not a Cubase limitation but a limitation of the .Wav file standard. No .Wav file can be larger than 4 GB, if you need larger files then use the W64 standard (64 bit Wave).

From the wiki https://en.wikipedia.org/wiki/WAV

Limitations[edit]
The WAV format is limited to files that are less than 4 GiB, because of its use of a 32-bit unsigned integer to record the file size header (some programs limit the file size to 2 GB)[citation needed]. Although this is equivalent to about 6.8 hours of CD-quality audio (44.1 kHz, 16-bit stereo), it is sometimes necessary to exceed this limit, especially when greater sampling rates, bit resolutions or channel count are required. The W64 format was therefore created for use in Sound Forge. Its 64-bit header allows for much longer recording times. The RF64 format specified by the European Broadcasting Union has also been created to solve this problem.

@KHS: Are you sure, there is such a big WAV file in the template?

In Cubase preferences > Record > Audio, there is an item: When Recording Wave Files larger than 4GB… The default settings is: Use RF64 Format, which solves the 4GB WAV file limit issue. But I don’t know, if there was a WAV file recorded to the template.

Yes I’m pretty sure about the Wav file size limit. However if that is the actually problem with OP, I’m not sure about. It could also be a problem if OP is only using the 32 bit version of Cubase 8.5 (don’t know if that is the case), albeit that should only give RAM limitation but one newer knows.
Also it does seems that OP is not actually recording as it would take many many hours of recording to hit the 4 GB file size limit and as soon as you hit stop then the next time you start to record it should record in a new file.

Maybe OP can explain a little more what he is trying to do and how he do it?

I mean, how do you know, there is such a big file in the template?

Well read the OP again. He said it was working fine until he hit the 4 GB file size limit.

I have read this. I just wonder, where does this file size come from (what was my 1st question).

@metrosuperstar: It would be, if you could explain. Thanks. :wink:

The project file itself doesn’t contain the Audio files (these are handled externally). So if really the CPR file is 4GB, then it must be something else.

In response to the questions asked… this is NOT a wav file. This is a TEMPLATE file, therefore has the .cpr extension. I am using thousands of tracks (all disabled), each one loads an instance of Kontakt. I don’t “know” why such a thing bloats the cpr as I thought that the bulk of a cpr file was symbolic links to outside resources.

@Martin.Jirsak

Read the Wiki link I posted above. Basically the 4 GB limit comes from the fact that Wav files are using a 32bit Integer file header and thus cannot support larger files.


@metrosuperstar

Are you using a 32bit or 64bit Cubase version?

Hi Martin, I’m using 9.5.10 Pro (64-bit). Inside Cubase I use 24-bit and have processing precision set to 64-bit.

I know this WAV limitation and the reason. My point was, the WAV cannot be the reason here.

Cubase 9 and Cubase 9.5 is 64bit only. So I’m sure he is using 64bit Cubase.

Yeah, I got that now with the clarification from metrosuperstar. I do suspect it is some kind of RAM issue though, either from running 32bit Cubase or simply because the Project file combined with all the Kontakt instances are using more RAM than he has but not sure though.

64-bit Windows 10, 64-bit Cubase 9.5.10, 32GB RAM

Maybe just for a test, try to rename the folder in which your Kontakt dll is located, to see if Cubase will open the file when it cannot load all those Kontakt instances.

Some clarification would be helpful here.

Since the error message in the OP does not mention file size how do you know that’s the issue?

I suspect that the file size idea is a red herring.

OP message does mention that he hit the 4 GB file size, hence i thought he was talking about a 4 GB Wav file but that is not the case.

Right. I’m saying that the assumption about this being caused by file size is erroneous.

It is conceivable that a cpr file could be corrupt, and the file system could show its size as being enormous.

I was able to reproduce the error a few times when building up templates again and hitting that point. However, Steinberg does not think that there would be a ceiling on file size but maybe has to do with RAM use at a certain point. Don’t know. Weird. Tracks are disabled. I have 32GB RAM. Anyway, I decided to break up my orchestral templates in smaller templates and then use Import Tracks from Other Projects if I ever want to bring in more stuff. Just for my own education though… is it possible yet to copy a track (or folder of tracks) from an open project onto another? This would be quicker than using the Import Tracks option.

Hi,

I would like to reproduce it here.

Could you provide one of your large template? Or multiple templates, which crashes when I combine them? It would be easier to reproduce it this way then just to try to make a large template, and don’t know by which data should I fill it in. Thanks.

You cannot copy the tracks, you can copy the data from project to another one.

Maybe Track presets would help on your case?