5.0.20 not working with Groove Agent [Solved]

If I create a new project, and go to apply a playback template, the GA templates are not there.
If I open a project that was working with GA under 5.0.10, I get
This project references a playback template playbacktemplate.hssehsogase_pro that is not installed on this system
Of I OK that, then I get this popup:
Warning; Some fields missing in file: barNumberNotationOptions, berNumberNotationOptions.

When the project displays, the drum track is wiped clean, and I can’t use the keyboard shortcut to add muy MIDI triggers back into the project.

I was able to clear this up by reinstalling GASE, its content and Dorico proper.

But there is some problem lurking in the upgrade process.

Sounds to me like you’re opening Dorico 4, and not Dorico 5. You would only see the “missing fields” warning when opening a project last saved in Dorico 5 in Dorico 4.

Yes, I think that is probably true. Unfortunately, I did not record my exact steps. Here is the best of my recollection:

  1. I used Download Manager to install 5.0.20. It asked for a reboot after the installation
  2. I used Download Manager to install the extra jazz extension for GA.
  3. I used Activation Manager to synchronize my licenses
  4. I double-clicked on a project I had been working on with 5.0.10, and that produced the messages. I don’t believe I uninstalled Dorico 5. It is likely this actually launched Dorico 4, but I didn’t notice that at the time.
  5. I created a new project in Dorico – and I expect this was probably D4. It did not have any support for GASE.
  6. I used Download Manager to remove and re-install GASE and the various content libraries
  7. I also re-installed D5.0.20 at this time

By then, everything worked. My confusion is step 4. I don’t believe I had uninstalled D5, so I don’t know why D4 would have launched