5.1 hang

Hi,
I tried to close a file and Dorico hung. I eventually force quit it.
Dorico 5.1 created a diagnostics report (link: Sync.com | Control Panel).




Attached are three screenshots:
(1) Steinberg Download Assistant showing what I downloaded (AFAIK, I don’t need Indian Drum Basics, Groove Agent SE 5-5.1.20-Instrument, Groove Agent SE 5-Content, Jazz Essentials, nor Dorico 5.1 Version History).
(2) Splash screen saying the audio engine is taking longer than expected to respond.
(3) Splash screen saying Dorico cannot connect to the audio engine and will quit.
At this point, if I re-launch Dorico 5.1, the splash screens repeat and I cannot use Dorico.
Thanks for any help you can offer!

If you end up in this kind of situation, the nuclear option is to restart your computer. But you should also be able to run Activity Monitor and force quit the zombie VSTAudioEngine process, and the hanging Dorico process. Wait a few seconds, then start Dorico again, and hopefully everything will come back up correctly.

1 Like

Thank you, Daniel. That worked. :slight_smile:

I’ve spent hours today trying to fix the same problem - after also losing much of the day attempting to reload inexplicably lost sounds and looking for an access code that I’m pretty sure I’ve never been in possession of (for HALion, which I thought came with Elements…). Anyway, one issue at a time. I’ve restarted the Mac countless times, quit VSTAudioEngine and Dorico in Activity Monitor, cried a bit, resigned myself to the fact that this project isn’t going to be finished for tomorrow (despite the fact that this morning I only had a couple more hours work to do on it…) and searched for various solutions. Now I need an actual, genuine solution, before I punch straight through my monitor/give up music/return to pen and paper…
Here’s a diagnostics report - Dropbox - Dorico Diagnostics.zip - Simplify your life

Update - earlier today I could at least open other Dorico files and utilise playback. I have just discovered I can no longer open any Dorico files…

I’m really sorry to hear you’re having problems getting Dorico to run reliably on your computer.

From the diagnostics you’ve attached, I can’t see any obvious smoking gun. A couple of the application.log files are missing, which I’m sure corresponds to the times you’ve been unable to get Dorico to run, or it’s hung or frozen shortly after running, but unfortunately if there’s no logging available to give me a hint what’s going on, I’m not sure what to suggest.

It looks like almost all the expected content is installed except for the HALion Symphonic Orchestra presets, but that shouldn’t stop Dorico from running properly.

Please try restarting your computer once more, then run Dorico by double-clicking its icon in the Applications folder, rather than by trying to open a specific project. Does it make it as far as the Hub window? Are any errors or warnings displayed along the way? If you then start a new project from the Create New page of the Hub, does the project open as expected? If you add a few notes, do they play back?

1 Like

Thanks for replying, Daniel.
I had already tried running Dorico directly from Applications and then opening the file, but that was unsuccessful.
Dorico has decided to work today, and I’ve managed to create a couple of simple projects (a lead sheet and a solo piano chart) which DID play back, but the troublesome file (a big band score) is still not having it. It opened successfully, but won’t play a sausage.
Any help at all would be hugely appreciated. Will send whatever’s necessary.

Elements just crashed (with the big band file open) and displayed this…


… which is what it was doing yesterday.

The error message says you don’t have a HALion 7 license. Did you ever buy a HALion 7 license? Because that is different to HALion Sonic, which is included in the Dorico license, but HALion requires an own dedicated license.
So it appears as if the projects is using HALion but there is no license for it around and then it just quits.
If you get Dorico running at least until the hub window, please choose from the menu Help >Create Diagnostics Report and post the corresponding zip file here. Thanks

2 Likes

Hi Ulf.
This is precisely what I don’t understand. I haven’t bought the full HALion, so how/why has Dorico started using it/trying to use it, particularly in the middle of a session when I hadn’t knowingly changed any settings? Also, in case it makes any difference, I’m actually using Kontakt for all my sounds.
See above for link to Diagnostic Report. Daniel has already commented on it. It’s too big a file to post directly.
Thanks in advance for your help with this.

But you have HALion 7 installed, that’s what the logs are telling me. And Dorico tries to load HALion 7 as well, so from that perspective it is normal…
It’s late here and I’ll continue having a look tomorrow morning…

1 Like

Perhaps you installed the Halion 7 trial?

1 Like

I have no recollection of doing so (which is not to say I didn’t…)…

We’re talking full HAlion, as opposed to Sonic?
As Janus says, perhaps I downloaded the trial version. I just have no recollection and don’t usually do trials.

Anyway, thanks Ulf. Speak tomorrow.

Hi @gmbamford ,
in the Dorico preferences on the Play tab, I can see that you are set to use the best available HALion plug-in and that is HALion 7, because you do have it installed.
Instead you better select the other option “use preferred” and then as the “Preferred HALion plug-in” you choose “HALion Sonic”.
And then, with your big band project, reapply a template . That will unload all previous VSTInstruments and instantiate new ones and automatically connect. In that case HALion should not be used any more and HALion Sonic instead.
Please try that out and see how it goes.

1 Like

Hey Ulf, thanks for the advice - I think we’re getting somewhere.

I’ve done as you suggested…

…and everything looks like it should be good to go…


… but still no playback.

Here are the current diagnostics -
Dorico Diagnostics.zip (2.2 MB)

Update: I set gmbamford up in a remote screen sharing session, case solved.

1 Like

He did indeed.
What’s more, he did it with patience and understanding, and I am forever in his debt.
Thanks Ulf :nerd_face:

2 Likes