504 gateway time-out error

Trying to download Dorico se to try the program out but keep getting an error code: 504 gateway time-out. Is there a problem with the server?

I have the same problem - with the download assistant. I even cannot download this program. Always this 504 gateway time-out! How can I get my software? (Dorico 4.0)

@Christoph_Muller and @isaacmbda

Welcome to the forum!

I can’t really help you but I’m guessing the Steinberg team who monitor this forum will be keen to know what systems you are running etc.

1 Like

Hi, what if you go to the Steinberg website, select Support and then Downloads. Can you download the installers from there?

Have a look here (for Windows users)

Much better to just download the Dorico installer from Steinberg directly.

Copying the app that someone has ‘shared’ is unwise – you’ve no way of knowing if it’s complete, up-to-date, or compromised with malware (either knowingly or unknowingly).

It seems that the Dorico installer can be downloaded indeed.
However activation of some sort may be required and then the Steinberg Download Assistant could be useful.
I understand your statement about using this ‘shared’ app, but you did hurt my feelings though …

Yes, you’ll still need the Steinberg Licence Manager, possibly the eLCC, and who knows what else. The SDA can be downloaded from that page, too (assuming the 504 problem isn’t coming from Steinberg’s servers.)

Apologies. Its always worth a think before a click, though!

The link you post for downloading the SDA doesn’t work. That’s actually the whole problem. Hence my initiative to put the SDA (for Windows) I have as backup on a Google drive and make it accessible on this forum

I also noticed it today. Following your instructions and wanting to download the SDA for mac, when clicking on the link comes the “504 gateway time-out error”. I tried with both Firefox and Safari. (Just checking, not that I urgently need it now)
This is the last site that creates the error: https://r.mb.steinberg.net/sda-latest-mac

This also appears in Steinberg Hub in Cubase

1 Like

I’ve tried it both on Microsoft edge and google chrome. Same issue. And when I go to their website, I can’t even click anything there - there’s simply a red arrow going around and around…

Sadly the website is stuck too - I can see it but it won’t load enough to allow me to even click on the support tab.

I’ve alerted my colleagues in our digital services team. I imagine they must already be aware of the problem and are very probably already working on restoring the missing services. Please accept our apologies for the inconvenience caused.

1 Like

I’m getting the same error message while trying to download Dorico. Does this happen a lot?

Only once, that I can remember. FWIW, I can download the SDA and Dorico from Steinberg’s downloads page without problem now.

Welcome to the forum, @hpburkett. I don’t believe we had any outages in these systems a few days ago, but please do let me know if you’re still having problems getting Dorico installed.