6.03 - Automation points: Bug or By Design?

Hi. Have just installed 6.03 on Mac, and noticed that the Automation points no longer show unless you hover over the automation track. Is it now supposed to do that, or is it a bug that has been introduced? I can’t seem to find a setting anywhere to change the behaviour.

It might seem small, but it’s a bit of a pain now when trying to match up up automation on different tracks - I now have to hover over one, move the cursor to that position and then alter the other track.

If this is now by design, can we have an option to go back to the old behaviour please?

Thanks.

Steve.

I just noticed this too and I HATE it! :imp:
Why Steiny, why in case you change something like this you don’t let us decide OURSELVES whether we prefer it or not - simply with a checkox in Preferences / Automation settings??? Let me tell you this is a show-stopper for me and I am forced to go back to 6.0.2 only because of this stupid decision of yours! :imp: I am really angry - I mean who asked for it in a first place?? Although it might LOOK elegant (to someone) seeing all automation lanes without the actual points, for editing it is COMPLETELY UNUSABLE!
Damned :unamused:

…not to mention that contrary to what Release Info says:

The visibility of handles for editing automation curves is zoom-dependent. When hovering with the mouse over automation lanes, the automation handles are displayed without zoom-dependence.

…when I Zoom Full the project, I can’t see them at all even if I hover over the lanes! :imp:

Ah right, I hadn’t seen the note about them being Zoom independent and prior to 6.03 I hadn’t noticed it. Does that mean the amount of Zoom has been changed? If I zoom in quite close so I only fit about 5 or 6 seconds on the screen then they do appear - it was not like that before.

Prior to 6.0.3 there was nothing to be noticed as this idiotic “feature” appears only in 6.0.3…
I just rolled back to 6.0.2 and UF what a relief! I can see my automation points AGAIN and ALWAYS no matter what zoom ratio I use and no matter where my mouse is…
Thank you Steinberg - I really wonder how the “real life” beta testing is happening as this workflow change must bother anyone who does even very simple automation in the project… :unamused:
Let (also) the musicians / engineers do the testing for you - not only the technical people!

oh…this makes me very nervous…

@Steve: please, can you post a screenshot of this dubious behavior? many thanks!

This is my usual zoom level where I can normally see the handles:
Screen 1.JPEG
This shows what happens if you hover the mouse over:
Screen 2.JPEG
This shows zoomed right in to the point the handles appear. As you can see I can ony fit 2 of the handles in view now:
Screen 3.JPEG
Hope that works as never added pictures before!

Steve.

Steve, many thanks for your fast response!
And yes, your screenshots are working - in contrast to the automation points…
:open_mouth: :cry: :imp:
This is just unreal. I can´t believe it.

erm…I hope for C 6.1

Central.

Actually I had this behaviour in 6.0.2 and it aggravates me to no end. It happens for me on the tempo track, and because the track is so compressed, it looks almost like one straight line when a tempo changes from 120bpm to 130bpm, for example. You would never even know the tempo change was THERE if you didn’t hover your mouse.

A preference to enable/disable this behaviour would be GREATLY APPRECIATED, heir lords at Steiny…

I agree, I had issues in telling about tempo change.

Yes please, +1, I’d like a preference or simply go back to the old method.

For me it’s quite important to see all the handles quickly across a project so I can make sure that say chorus 2 has the same automation as chorus 1 say. Without the handles most times I can’t see there’s any automation at all especially if it’s subtle, like 1dB for pushing a single vocal word. Tempo changes are even more important, particularly because they’re quite often small, e.g. 4bpm speed-up into a chorus.

Mike.

I don’t have this issue. The points are there all the time for me.

Must be a bug then? Are you on Windows or Mac?

Then it is you who (also) experience a bug as Steinberg did mean to hide the automation points (when not hovering over the automation lane)

I’m using Windows 7 64bit, and the points are there no matter what I do.

Maybe, seems to be what you guys would prefer though yes ? Wonder how I or why I don’t lose them.

I actually like this feature, for me it gets rid of screen clutter. I agree though there should be a preference for it and perhaps a zoom setting for how zoomed you have to be in order to see the points. 6.03 working rock solid here, thanks steiny.

Was definitelty happening in 6.0.2: https://www.steinberg.net/forum/viewtopic.php?f=19&t=10936

Odd how some of you don’t have this and some do. If you read the post above you will see that in my case it didn’t use to do it then all of a sudden - apart from a brief remission - it did. This was mid-project. Bizarre and really hard to understand.

I’m pretty sure it only started in 6.0.2, I noticed straight away as the particular project had loads of automation in it. A big nuisance - you don’t realise how much you’ve been relying on seeing them until they’re not there, for all the reasons stated here. I think the only thing I’d been fiddling about in was the Automation Panel, might have made a few selections via it but not to perform any edits, can’t really remember, but it might be a place to try and get it to repro.

[EDIT] Seems to be hiding the points all the time now, even on older projects I haven’t touched in ages. Can’t even get the repro in the above post to work, either, darn it.

It would be nice to know what the behaviour officially should be.

[EDIT 2] Thanks to this post further down for pointing out it’s behaving as per the 6.0.1 release notes (p.9): https://www.steinberg.net/forum/viewtopic.php?f=19&t=11328&p=74622#p74622

So all of you with always visible points can consider yourselves very lucky! :mrgreen:

+1!
It looks so much cleaner now IMO

What beta testing?!! WE are the beta testers :nerd: