6.5 - Why is saving still so slow?

I’ve noticed auto save a little longer in 6.5. I wish it could work in the background because it is a creativity killer. I find that it is directly proportional to the size of the project and has behaved this way from the beginning. Pro tools doesn’t pause for auto save at all, so I can only assume that it is possible for Nuendo to behave the same way.

Dean

Update for reference to those having issues:

Been working with 6.5 Trial for a few days now. I see no increase in save times. 100+ tracks and 10+ VSTi on 5 minute songs.

Essentially, saving is invisible on this system. I think nothing of doing a “Save As” incremental save while in record mode. Again, N6.5, Win 7 x64, 16GB, 4770K. System OS is a hard drive. Streaming drives are Samsung SSD.

Most common aspect is see for slow saving seems to be Mavericks.

Naw, it’s not just a Mavericks issue. It’s been happening on Macs since Lion and N4, and PCs at least as long; there have been multiple threads in regards to this problem.

I don’t know why I had one especially troublesome import from previous versions; let’s just call it a corrupt file. But… outside of that, the behavior in my case (and I work on both Macs and PCs, despite my sig), is pretty predictable, and occurs when:

  1. The project is long-- has a lot of files.

  2. There are lots and lots of edits in said files.

It’s not unusual for one of my projects to run 20 or 30 hours, and the editing’s pretty intense. A lot of offline processes, etc.

My workaround is to bounce the edited files and “Remove Unused Media” from the pool. I tend to trash the originals-- not good workflow for everyone, but it works for me :sunglasses: but just removing them from the pool works as well, and if you save your project backups so that Autosave doesn’t zotz them over time you can have a comprehensive backup history.

Once the multitudinous edits and offline bounces are out of the pool, project saves and autosaves snappily again.

Would be great to get this (finally) fixed!

Chewy

I am on Win7 64bit.

Indeed: Slow Autosave was and is related to what Chewy said.

  • log project (lots of files)
  • more important if not ONLY important: The amount of edits/offline.

Esp using Variaudio and time warp in the sample editor (when having truckloads of vox) slows it down.

A 5 min song with moderat track count (lets say 50-100 incl bussing/fx) might safe quite fast… the project I am working on currently saves about 40 sec - of cours autosafe jumps in when hitting STOP.

This is basically a good thing. But usually I hit stop because I want to re-listen something or doing an edit. And then (while wanting to do something) waiting for 40 sec is quite workflowkilling I have to say.

Why it is not possible to:

Reduce autosave again: In N5.5 it was quite fast (it was slow some versions before) - of course needs a bigger project somewhat more time, but that project might have used - lets say - 2-3 sec…

Make autosave work in the background, without freezing everything.

It looks not very professional when the whole application (which is stretched via 4 screens) completely freezes every 10 minutes… I mean: Everything is frozen. Meters, GUI, playback etc… It can be irritating to the artist when you still have to record stuff … (“aaaahhm , well, wait a minute, it is saving… grrrr yea… wait”) as well as it nasty when mixing “can we listen to this part again?”… “aaaaahm, well, not yet, just wait… wait… it is saving again… aaargh… fck fck f*ck”

Basically I have the same system… but 32GB ram. other stuff is the same. Machine performs wonderful regarding about stability and cpu power…

I am getting wait times of more than 30 seconds with auto save too (on big projects). It is a big creativity killer. My experience is just like Brandy’s. Although usually when the project is so big that auto-save is lengthy, the tracking is done and I am just mixing but It does happen.
When I am mixing, my thoughts are always faster than my ability to execute them and it is especially tough to remember my future moves when the whole project pauses and I am annoyed and waiting. This has been an issue with Nuendo from the start although it is worse with 6.5.

Dean

With multicore processors and proper threading, it seems that this would be a correctable issue.

That’s exactly my problem!

In the past there was a version-update with “slow saving times fixed” - and yes - it was ok/fine after that. So please, Steinberg, do it again.

Damn I just lost 25 min of good mixing work due to a Nuendo freeze… I avoided hitting stop because I was mixing a part in cycle mode (so I was not interrupted by autosave) - I was just done with some stuff and then I accidently hit the “group” button on a big folder containing shitloads of tracks/edits - OF COURSE the events are not in sync and grouping could have some errors… but Nuendo freezes completely maybe because of the complexity of that task - while playback ist still running, I still hope that it will un-freeze but it does not seem… Oh damn

Brandy, there are 3 area’s which sometimes can cause troubles on some systems/projects. (not specific to slow save times, it should be transparant, no new bugs here)
Disable following preferences:

-Suspend VSt3 processing when no audio signals …
-Enable automatic hitpoint detection
-ASIO Guard

Might be worth trying.
Fredo

Hey Fredo,

though the crashes I had (and described in other threads) might not have something to do with those settings you mentioned I disabled those prefs today.

  • Auto Hitpoints are disabled since a while (I do not need that, if I need hitpoints I can create them at any time)

  • the suspend VST3 processing is a great feature and turning this off increased the CPU load of that 508 track project from about 55% to 80% - but I still have headroom… if I will need more juice in the final sessions (not all orchestration imported yet) I will re-activate it again because a project like that has a lot of “this track is only used in one part of that album” stuff…

  • Asio Guard: I never was able to understand everything behind it, it seems to decrease my system load a little so I had it activated, now it is disables…

It seems to me that I have a better reacting system now and at least today I had no crashes (was avoiding all those critical actions though).

Those 3 prefs are great features and I do not have the impression that they are causing problems - but as you said - maybe I have less overall issues now when handling that large project.

P.S: Saving Time is still slow :wink:)

I’m also suffering from slow saves since upgrading to N6.5.

It affects all saves, both auto-saves and straight command-S saves. The whole system beach balls for 50 seconds (no joke, i put a stopwatch on it) before working again. This is on a project with just 49 tracks inc groups and fx. The first time auto-save kicked in it looked just like a crash and I nearly did a force-quit.

In all previous versions of Nuendo a command-S save was near-instantaneous for me.

Please fix. Right now I’ve had to turn auto-save off completely which worries me.

Oh, this is N6.5 on a 12-core 2010 Mac Pro running 10.9.4

I’ve realised that every time I do a save, it gives me about a minute to check this thread and see if anyone’s responded. In fact, I’ll happily take suggestions for anything useful I can do in the 50 seconds while my Mac is locked up. :slight_smile:

PS just tried it and found I can pick up my guitar and practise SRV’s solo from “House Is A Rockin’” three times over in the time it takes my N6.5 project to save. So it’s not going to waste.

Watching Bud Spencer over here during the saving times.

But what to do when my Bud Spencer DVD Box is all done?

Please Steinberg, fix this ASAP… It really hurts… and it is even dangerous because I am already thinking about disabling Auto-Safe - which is not a good idea because I am used to it and barely hit ctrl-s

Huh. So… I created a new project, based on the one I was having slow-save-time issues with. I saved it as a template, then deleted all the audio from the pool, brought in new audio (different show but same mix layout), dropped it in the project, added video, did lots of edits etc.

Saves in this new project are near-instantaneous and have stayed that way no matter how much more complicated it got. Saves take one or two seconds max, rather than taking nearly a minute to save as the old project did. It has almost as many tracks, just as many plugins and groups and effects.

So, what can I say. Weird.

Over the next few weeks I’ll try to investigate when the opportunity arises.

The only difference I can think of right now is that the new project was built from scratch in N6.5 (albeit based on a template created from the problem project) whereas the old project started out as a Cubase 6 file opened and edited in N6.5.

Uh! Mh… öh… well…

Indeed the project I am currently working on is made in N6… but too big and too much “mixed” to transfer in a fresh project…

I have the feeling that it has to do with vari-audio-editing.

Yesterday I was tracking vox in another project (another band) - everything was done/rec in N6 but the last two rec sessions (vox) I did in N6.5. Saving was still fast, truckloads if tracks, edits etc… All songs in one project, all the recorded stuff is not consolidated for mixing yet… Saving was fast…

Then I started to time-warp a couple of backings in the sample editor - immediately saving time increased A LOT.

I realized something strange here as well: In 6.0 I can timeworp (sample editor) or time stretch (project window) in realtime - in N6.5 Nuendo stops first to “calculate” something, I have a process bar… like the one I have when I use vari audio…

Had a sudden thought… I tried saving my problem project (which was still taking exactly 50 secs to do a save) out to a whole new project using Create Backup Project. That also copied across all the audio that was in use.

Open the new backup project and it does saves in 10 seconds. It still beachballs, but doesn’t beachball for anything like as long.

That might be a temporary solution for some of you?

Still doesn’t explain why the other project I made saves in only 1s or so. But getting closer.

Mh, interesting! Will spend some time on this as well… Currently I am somewhat under a deadline - for now I am handling it in a way Rotund recommended in my other topic. I had a data-loss caused by “not manually saving” and lost almost a day.

http://www.steinberg.net/forums/viewtopic.php?f=194&t=63319

I know this sounds stupid but when autosave saves every 10 minutes (and I set bac files to 15 or so) I have nice incremental saves - I usually only save manually when doing something “critical” and I want to “save as” before.

In the current project I have a strange issue (never had it before) - the “save, not save, abort” (do not know about the english version of the dialog, I have German windows / Nuendo) dialog jumps in ALWAYS when I want to close the project - even when I just saved a second before… So I hit ctrl-s and had the hourglass for 50 sec - but as it seems autosave had jumped in just in the second I hit ctrl-s - so my ctrl-s was blocked instead of that autosave was active… So - I closed the project, clicked “do not save” and Nuendo deleted all bac files from that day… what a pain!

This was user error - but it was forced by the slow saving time (usually I hit ctrl-s again when I am not sure but I avoid it these days to hit ctrl-s twice) - in combination with the issue regarding that “save, do not save…” dialog.

Well - for now I disabled autosave - and it has some real advantages:

Auto-save does not block my DAW in a critical moment (after hitting stop to hear something again)
Instead of that I am NOT interrupted in my flow anymore
I can hit ctrl-s when I am actually listening to something, because playback is not interrupted during those 50 sec

Update:

Started a new project yesterday… Something simple… 70ies Metal, recorded more or less live… so - very very basic editing only, not much tracks - currently just a handfull of plugins… Started in N6.5 (using a 6.0 template though)

Manual saving is done in a fragment of a second.

Autosave CAN took 20 sec… I know this is strange but sometimes it is fast as the manual save - sometimes it “freezes” for 20 or even more seconds - I was frightened in the first moment because I thought of a Nuendo Crash/Freeze.

I have NO offline processing, NO timewarp/vari-audio in it.

We’ve hit long save times here as well. We have two different machines (both are mac, though) and are using 6.5 on each. One project has 256 files but each file is almost 3 hours 26 minutes long. There is also a video file attached of 1 hour 13 minutes. One plugin running. No foolin’ this thing takes almost ten minutes to save.

Is Nuendo re-writing the audio image files every time it saves? I ask because I got rid of the peak file folder and let it make them again and that’s taking that kind of time.

I also have another project that has 24.4 thousand files in use of varying different lengths spread out over around 2 and a half hours. This also take 5-10 minutes to save.

Help!

Thanks!

Darren “Time On My Hands” Ingram