64bit plugin is blacklisted

Hello guys,

I’m having an issue running 64bit of SNESVerb. Cubase blacklists it! As I understand, 64 bit plugin is supposed to work perfectly with Cubase pro 10.
My Cubase is up to date, no issue about folder permission. I also tried to move .dll to other folders that is default for plugin scanning but I didn’t work out as well. Can anyone help me figure this out what happened please. Please check my attachment to see the screen capture.

I’m using Windows 10, Cubase pro 10

Thank you in advance.
64bit blocked.PNG


Not all 64-bit plug-ins must pass the test. As I can see, this is VST 2plug-in. Cubase 10 accept only VST 2.4 or newer. I would say this is the problem.

And btw even a 64-bit VST3 plug-in can be blacklisted, if an issue (which might lead to a crash) is detected during the very 1st plug-in scan.

Oh, I didnt know that. Thank you for your answer. I recently tried Jbridge with the one that is 32bit and it works fine. I was wondering I should buy jBrigde (if there is no way to make 64bit work)