7.0.40, realtime pitch-shift crackles render to files!


Realtime pitch-shifting has been full of crackles and pops since, I don’t know maybe Nuendo 6.0, but this new update 7.0.40 really ruins it toally because now pops also render in the file!!! I noticed this after several attempts to render a short clip with just two semitone shift up, and Elastique Pro - Pitch algorithm set in Preferences (which always worked before). I’ve now gotten back to Process pitch-shifting manually which is like going back a decade.

Please fix this or tell me a workaround - pitch-shifting in realtime is very essential when making sounds and soundscapes for games and such. If I cannot trust the pitch-shifted clips to render without clicks and pops, I cannot go back to my old projects, because it’s so much extra work and for new ones too.

Just hoping now I can revert back to earlier version somehow…?

Working on latest OSX Yosemite

Can you post a step by step instruction so the rest of us can confirm it?

Sure, Preferences are Elastique Pro - Pitch, which I have used in the past. Stretching is Poly Complex, but probably doesn’t affect this matter, I didn’t stretch the clip.

I have an stereo audio clip on the timeline on 48khz-24bit project with Voxengo Elephant at master bus, but nothing else. Clip is few secs long, has curved fade in the end. It has transpose value of 2 semitones. Sometimes it crackles when playback, especially if starting nearby, sometimes not. Crackles are random. This happens usually with all the transposed clips here and there, and has happened since Nuendo 6, I suppose. Back in the day, someone said here that it could be an issue of some SSD’s. Well, I have changed SSD since and it still happens. Project resides on my system drive, but in my experience it doesn’t make any difference where it is. I use system audio on laptop, but same thing happens on my desktop via RME Fireface UC.

Neverthless, in the past when rendering clips like these, crackles never showed in the rendered file. Now it shows, all the time. I render this file to 48khz 16bit and there’s crackles. But everytime in different places, sometimes one, sometimes a few. Just like playing back in the timeline, but now also in the file. When I pitch-shifted as Process and rendered it out without realtime transpose, all fine.

I noticed this change immediately when updating to 7.0.40 because I use this feature daily when making audio assets for games.

Thanks. I’ll have to check this later. I had to do a quick time-compression today and got strange playback. Bouncing the file solved it, but I’ll test it later.

This is a continuing no-go issue for me, it is just too much extra work to offline process all pitch-shifting. Is there some solution coming up or maybe some workaround? Or is there some easy way to revert back to 7.0.35 in OSX? I can’t find the older update anymore at Steinberg’s site.

It is highly disappointing to have such a basic feature like this to be broken suddenly. I’m surprised nobody else has reported it, is there something peculiar in my setup or what?

Hmmm, interesting. I recently updated my laptop to 7.0.40 and had similar issues. I was pitch-correcting a vocal, and all of a sudden the files started falling apart. The vocals began to sound as though they were recorded distorted. So much, that I went back to the client and told them to check their files.

Anyway, when I took that same project out of the laptop and dropped it into my desktop, which is still running the previous version, everything was normal. I didn’t place much thought to it since I was going to work the project in the desktop anyway. I’m interested if anyone else has experienced similar issues.