7.5.2 installer fails!

My first attempt to install the 7.5.2 update completed for some portions but not the main x64 update. I tried 2 different downloaded copies of the installer but get the same result.

After the first try failed, I pulled a fresh copy. It then detects the portions that did upgrade but fails again on the main update. Please advise.

Windows 7 is fully updated.


Do you have 7.5.0 (or 7.5.10) 64 bits installed before updating to 7.5.20 ?


this has been discussed several times, including a thread I replied to yesterday:


updating from 7.5.1 x64.
should this be a sticky topic?
Sorry Fabio, but running Repair from Control Panel\All Control Panel Items\Programs and Features
prompts the user to install the media. see attachment. no can do from a downloaded installer.

Yes you can do this using a downloaded installer. You will need a software to create a virtual drive (or just burn the installer on a disc).

Thanks! will try a physical burn. Just to be clear, exactly which installer? 7.5, 7.5.1, 7.5.2 may both fit on a cd-r. Don’t forget there are other various installers on-line.

The older previous installers worked well and did not need fixing. Is this improvement (?) due to copy protection issues? Why perform validations that fail on good working installs? It seems poor practice to blame the end users, as I have seen in similar threads. Thanks for the suggestions.